question

PetriPuoliHonka-4917 avatar image
0 Votes"
PetriPuoliHonka-4917 asked GraceHE-MSFT commented

Connection to RDS server slow from non-domain joined computer

Hi,

We had the same issue with our earlier Windows server 2012R2 RDS server, but we coped with it. Now we upgraded to a Windows server 2019 running RDS.
The problem is that all apps run fine on remote computers that are domain joined. When you try to use the apps with a computer that is not domain joined it is really slow, unusable most of the time. Sometimes, like one out of ten, it works fine, but most of the time it is just slow.
This happens with multiple computers in different networks. It is not a network issue on internet connections. There is no VPN connection involved.

HTTPS port is open to the server and I have also opened UDP 3391 port, but it does not seem to help.
https://www.itpromentor.com/rds-performance-boost/
This is what i tried.

The RDS server has all roles on a single server. It is only used by around 7 people.

I have really run out of ideas.

remote-desktop-services
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,
Thank you for posting your query. According to your description, more detailed information would be grateful.
Are you using RDP to connect? What's the version of your RDP?
If you all use the internal net, would the same problem happen?

0 Votes 0 ·

Unfortunately there really are not any non-domain joined computers at the office in LAN.

Yes we are using RDP. The server is an Windows 2019 Standard server. The clients are all Windows 10 computers.

0 Votes 0 ·

Hi,
Thank you for your reply.
If you uncheck Bypass RD Gateway for local addresses in Server Manager RDS Deployment Properties RD Gateway tab, do you still see a delay for external clients? Is the delay less/more or exactly the same? Please remember to refresh the RDWeb page if you have it open after making a change to the Deployment (wait for the change to complete first).

0 Votes 0 ·

0 Answers