question

princerastogi avatar image
0 Votes"
princerastogi asked TravisCragg-MSFT edited

Vulnerability assessment findings on SQL VM Showing wrong info

We have few Vulnerability assessment findings on SQL VM from Security Center for which there is no Remediation step and add to baseline is also disabled. When I am running that query on SQL Server for that specific database, I am not getting any result back. based on this I am considering everything is correct on that database but why it is showing under Vulnerability assessment as High Priority.

This is showing same as since last 3-4 days.

79301-image.png


azure-security-centerazure-sql-virtual-machines
image.png (41.7 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

TomPhillips-1744 avatar image
0 Votes"
TomPhillips-1744 answered princerastogi commented

What do you get if you run this:

 EXEC sp_change_users_login @Action='Report'; 
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Already did that and there is no orphan user in that database.

0 Votes 0 ·

Are you sure you are running it in the correct database?

Are you using the most current version of the assessment tool?

0 Votes 0 ·

Yes, I am running this on correct database and Assessment is running on Azure SQL VM using Azure Security Center.

0 Votes 0 ·