question

GavinRoss-3568 avatar image
0 Votes"
GavinRoss-3568 asked ·

OAB not downloading and not showing in Outlook Test

We are having an issues with all users when downloading the address book. The issue started after the last CU update on Exchange. The users get the following error message when downloading. error: (0x8004010F): The operation failed. An object cannot be found. This is what I have run to check on where the issue could be;

Get-OfflineAddressbook | fl -- Looks fine
Get-OabVirtualDirectory | fl server, Name, ExternalURL, InternalURL, auth -- Looks fine
Get-OabVirtualDirectory -ADPropertiesOnly | ft Identity, url -AutoSize -- Looks fine
Get-ExchangeServer | Get-OabVirtualDirectory | fl Identity, ternalurl -- Looks fine
Get-Mailbox username | fl Name, OfflineAddressBook,Database -- Looks fine
Get-OfflineAddressBook | fl Name,Vir*,Distri,Gen*,IsDefault -- Looks fine
Get-Mailbox -Arbitration | where {$_.PersistedCapabilities -like "oab"} | fl name, database -- Looks fine
Get-OfflineAddressBook |fl VirtualDirectories -- Looks fine
Get-OabVirtualDirectory |fl identity* -- Looks fine
Get-offlineaddressbook | fl WebdistributionEnabled,VirtualDirectories,Identity -- Looks fine
Test-OutlookWebServices -identity:username -MailboxCredential (Get-Credential) -- This gives me the following errors;
Autodiscover: Outlook Provider Failure
Offline Address Book Skipped

When checking the OAB location on the server, the oab.xml file has a timestamp of today, so I know it is getting updated and there are no problems with the GAL. Does anyone have any suggestions on how to get this to work again?

Exchange 2016 CU19 running on Server 2012R2.


It was working prior to updating the CU from 16 to 19. This was done about 3 weeks ago and we just noticed the problem as a new users did not show up in the OAB.

Thanks,
Gavin

office-exchange-server-administrationoffice-exchange-online-itprooffice-exchange-server-connectivity
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

ZhengqiLou-MSFT avatar image
0 Votes"
ZhengqiLou-MSFT answered ·

Hi @GavinRoss-3568 ,

You could run the cmdlet with | FL to check the error info:

 Test-OutlookWebServices -identity:username -MailboxCredential (Get-Credential) | FL

So it will show the error message of Autodiscover. And the OAB check skipped because Autodiscover failed this is expected.

Also check Autodiscover with E-mail autoconfiguration: Holding Ctrl and right click Outlook client button, and Test Email autoconfiguration check the log. Or using EXRCA to test.

Regards,
Lou


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thanks, gave me more info on what was causing the error. I was able to fix it by running this command...

(Set-OfflineAddressBook -Identity "Default Offline Address List (Ex2013)" -VirtualDirectories $null -GlobalWebDistributionEnabled $true)

Thanks,
Gavin

0 Votes 0 ·