question

ChuckReynolds-7321 avatar image
0 Votes"
ChuckReynolds-7321 asked Dave-0266 answered

Problem with %20--use-spdy=off%20--disable-http2

When I click on a hyperlink imbedded in an email (Outlook), the string "%20--use-spdy=off%20--disable-http2" gets added to the web address, and the address does not open properly. I can get to the address by deleting the "%20--use-spdy=off%20--disable-http2" string, but that's a hassle. I use Chrome as my default browser.

office-outlook-itpro
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Just ran into this same problem today with Excel and spent the last 4 hours trying to figure out what the hell was broken.

What solved the problem for me was a registry edit to disable the http2 protocol.

https://docs.vmware.com/en/VMware-Horizon-6/6.2/com.vmware.view-agent.directconnectionplugin.doc/GUID-BE0738EC-E35E-4215-8E1E-1F08F911D592.html

0 Votes 0 ·
JeffYang-MSFT avatar image
0 Votes"
JeffYang-MSFT answered JeffYang-MSFT edited

Hi @ChuckReynolds-7321,

Welcome!

Does this issue only happen to the Chrome browser? In order to further confirm your issue, I would suggest you to try opening the same link via other browsers such as Microsoft Edge to see if the issue has any difference there.

I tried search a lot about the "use-spdy=off" within your issue and found that much more similar issues point to the SPDY protocol in Google Chrome. So, personally, I would suggest you to repair your Chrome install and try disabling the SPDY in Google Chrome to see if the issue could be resolved.
For more information, please check:
How to disable SPDY in Google Chrome
--use-spdy%3Doff & --disable-http2
(Note: Since the web sites are not hosted by Microsoft, the links may change without notice. Microsoft does not guarantee the accuracy of this information.)

Hope this can be helpful.


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @ChuckReynolds-7321,
Just checking in to see if above information was helpful. If you have any further updates on this issue, please feel free to post back.

0 Votes 0 ·

I was reluctant to disable spdy, so found a site with steps to take. https://kinsta.com/knowledgebase/err_spdy_protocol_error/. Notably, these steps did not work (though I skipped 2 and didn't do 5).

I ended up switching to Edge, and the problem went away. I switched right back to Chrome, and problem stayed away.

Like Edge for many reasons, but company uses Google for calendar, email, etc. Just easier to have Chrome as default, though I often run Edge in parallel.

0 Votes 0 ·
JeffYang-MSFT avatar image JeffYang-MSFT ChuckReynolds-7321 ·

Hi @ChuckReynolds-7321,
Thanks for your reply and sharing.
According to your description, the issue only occurs when using Chrome and can work fine with Edge. So, we might infer that settings within your Chrome browser might be the key of your issue. Since here we mainly focus on general issues about Outlook desktop client but know little about Chrome browser, if you would like to conduct further troubleshooting about your Chrome, I suggest you to contact the support of Chrome for more specific information. Grateful to your understanding and support.


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



1 Vote 1 ·
DavidJose-8060 avatar image
0 Votes"
DavidJose-8060 answered

Just ran into this same problem today with Excel and spent the last 4 hours trying to figure out what the hell was broken.

What solved the problem for me was a registry edit to disable the http2 protocol.

https://docs.vmware.com/en/VMware-Horizon-6/6.2/com.vmware.view-agent.directconnectionplugin.doc/GUID-BE0738EC-E35E-4215-8E1E-1F08F911D592.html

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Dave-0266 avatar image
0 Votes"
Dave-0266 answered

This is caused by an old linking of the standard app. Just assign another browser as standard app for browser and re-assign Chrome again. It's as simple as that. If it's not working - just reinstall Chrome and apply the standard app again. https://support.microsoft.com/en-us/windows/change-your-default-browser-in-windows-10-020c58c6-7d77-797a-b74e-8f07946c5db6

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.