question

08111028 avatar image
0 Votes"
08111028 asked JeffYang-MSFT commented

outlook 2013 does not sync emails until you open "inbox"

Hello. It looks like new mail is not showing up in the IMAP mailbox if that particular mailbox is not open. I have two IMAP accounts configured. If I send a message to both IMAP mailboxes from an external account, only the currently open (displayed) mailbox shows that a new message has been received. The other mailbox is not updated until I click on it and make it an open (displayed) mailbox.


I want both mailboxes to update and display the new message, no matter which mailbox is currently selected. Is there a setting somewhere that controls this? I am using Outlook 2013 on a 64 bit Windows 8.1 machine.

p .s. There is a suspicion that outlook cannot keep 2 imap sessions open at the same time. Thunderbird has this functionality.

Thanks for any help you can offer!

office-outlook-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

JeffYang-MSFT avatar image
0 Votes"
JeffYang-MSFT answered JeffYang-MSFT commented

Hi @08111028,

Welcome to our forum.

I did the same tests as yours in my Outlook(Outlook 2013(15.0.5319.1000)) and seems can successfully reproduce your issue.

When the "not sync" issue happens, have you tried manually clicking the "Send/Receive All Folders" button to see if the issue has any difference there? According to my tests, I found that when the issue occurs, I can immediately receive the new email in other mailbox by manually clicking the "Send/Receive All Folders" button. So, the key of this issue might be related to the sync frequency of the IMAP email accounts in Outlook.

As I know, in Outlook desktop client, we could define the send/receive operations of our email accounts on our own via "Send/Receive groups". So, in order to avoid the impact of sync delays on you as much as possible, please try the steps below:

  1. Select Send/Receive > Send/Receive Groups > Define Send/Receive Groups.

  2. Select All Accounts > Edit.

  3. Select one of your IMAP account from left-side-list, then check the "Include the selected account in this group" box.

  4. Make sure "Send mail items" and "Get folder unread count for subscribed folders" are selected.

  5. Select "Use the custom behavior defined below" under "Receive mail items" > right click the mailbox and choose "check all subfolders".
    80545-15-09-14.jpg

  6. Check the same settings for your another IMAP account and click OK.

  7. Then, check the second Schedule an automatic send/receive every n minutes option and modify the sync frequency time to 1 minute so that you won't miss the new emails for too long.
    80517-15-16-09.jpg

  8. Click Close and restart your Outlook to see if the issue becomes a little better.

For more information, you could check this similar issue: Outlook 2016 imap accounts don't receive automatically.

Hope this can be helpful.


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


15-09-14.jpg (73.2 KiB)
15-16-09.jpg (22.2 KiB)
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @JeffYang-MSFT, Thanks for the answer.

But it looks like I gave you little information. When I click the "Send / Receive All Folders" button, I receive messages in all my mailboxes. And if I set synchronization in the settings once every 1 minute, then I will also receive messages to all my mailboxes, but this does not solve my problem.

Actually what is the question. I noticed that outlook does not "open" an imap session if the required account is not open and, accordingly, messages will not reach until you open the imap session (until you open the required account). You can verify this by setting "Schedule automatic send / receive every n minutes" to 60 minutes and without manually updating mail using the "Send / Receive All Folders" button. You will receive a new message only on the account that you currently have.

0 Votes 0 ·

Hi @08111028,

Thanks for your reply.

Well, I can fully understand the situation that you described above, however, as I know, this is indeed how IMAP accounts work in Outlook desktop client(Outlook 2013, 2016, even the latest Outlook 365). And Outlook provides Change send/receive group settings options which I mentioned above to allow users to Schedule automatic sync on their own for better experience. This is by design, we might not be able to change this behavior.

Except for the Send/Receive settings we mentioned above, as I know, using Exchange email account can also be an alternative workaround.

Grateful to your understanding and support.

0 Votes 0 ·

Hi @08111028,
Just checking in to see if above information was helpful. If you have any further updates on this issue, please feel free to post back.


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

0 Votes 0 ·