question

tonitodux avatar image
0 Votes"
tonitodux asked LucasLiu-MSFT commented

Forwarding an e-mail causes two copies in sent items?

Hi,

I have a strange issue and I cannot wrap my head around it. When our secretary goes into her Outlook 365, and selects a shared Mailbox, there she forwards the e-mail to someone in the company - the sent items will show two identical e-mails in the shared mailbox. So far I am aware of there isn't a rule on the mailbox or on the server side.
We are using hybrid exchange setup with only one exchange server on-premise and online.
Where can I start to look for the possible cause?

Cheers!

office-exchange-server-mailflow
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

tonitodux avatar image
0 Votes"
tonitodux answered LucasLiu-MSFT commented

So the only solution which works for us is to remove all the checkmarks from O365 Console -> shared mailboxes:

83283-checkmarks.jpg



and do a registry edit i a form of:

HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Preferences
Note
The x.0 placeholder represents your version of Office (16.0 = Office 2016, 15.0 = Office 2013, 14.0 = Office 2010).
1. On the Edit menu, point to New, and then click DWORD Value.
2. Type DelegateSentItemsStyle, and then press Enter.
3. Right-click DelegateSentItemsStyle, and then click Modify.
4. In the Value data box, type 1, and then click OK.

This only works this way in our case, BECAUSE READ CAREFULLY we DON'T want the following:
when a user sends or forwards an e-mail from a shared mailbox, we don't want this e-mail staying in the private sent items folder of a user, only in sent items of a shared mailbox.

Without his mambo jambo, i think turning on the first checkmark would work normaly for most needs.

Thanks




checkmarks.jpg (38.3 KiB)
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @tonitodux ,
Thanks for sharing the solution again.
During this period, I have been testing the information you provided last time. According to my test:
1.First, I checked the registry in lab environment, but I didn’t see this registry key. Then I add the same registry key as you said and set its value to 1.
2.Check the “Copy items sent as this mailbox” for shared mailbox in Microsoft 365 admin center.
3.I tried to forward an email in the shared mailbox in the Outlook client, then I found two same email appeared in send items of shared mailbox. I also try to forward an email in OWA, but only email in send items.

This registry key only effect the outlook client, and if we both set the registry key and check the “Copy items sent as this mailbox”. There will be two emails in send items of shared mailbox.

1 Vote 1 ·

For more information: Want more control over Sent Items when using shared mailboxes?

In addition. In my testing process, after modifying the registry, please make sure to restart the computer for the modification to take effect.

1 Vote 1 ·
LucasLiu-MSFT avatar image
0 Votes"
LucasLiu-MSFT answered tonitodux converted comment to answer

Hi @tonitodux ,
Only one shared mailbox have this issue or or all shared mailbox have?
Is the user and shared mailbox in the on-premises Exchange server or Exchange online?

1.Please try to login to OWA and forward the email, then see if the same issue occurred in OWA. If the issue only occurred in outlook client, please make sure the outlook cilent is the lastest version.
2.Please re-create a new Outlook profile and add the shared mailbox again, then try to forward the email.
3.Create a new shared mailbox and assgin the permission to secretary, try to forward the mail in the new shared mailbox and see if there is the same issue.
4.Please check the message trace in exchange online or message tracking log in on-premises Exchange server to see is there a record of sending two emails.



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

tonitodux avatar image
0 Votes"
tonitodux answered LucasLiu-MSFT commented

Hi LucasLiu,

thank your for replying. The problem actually turned out to be the two check-marks which I put on every shared mailbox in our company:

81475-o365.jpg



After I removed the "Copy items sent on behalf this mailbox" check-mark everything was back in order. After sending the e-mail from the shared mailbox's e-mail address it appeared only once.

Cheers


o365.jpg (37.2 KiB)
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @tonitodux ,
Wow, great discovery!
Thanks for sharing the solution, this will help more people.




0 Votes 0 ·

I apologize, this did not solve the problem. I am still troubleshooting it.

0 Votes 0 ·

Hi @tonitodux ,
I will continue to assist you in solving this problem.
Have there been any settings changes before this situation occurred?
Will this issue appear when everyone forwards emails in the shared mailbox?

So if you uncheck "Copy items sent as this mailbox", will there be any new emails in "Send Items" after forwarding the mails? Use this to determine whether there are other rules that place the sent mail in the "Send Items".



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


0 Votes 0 ·
tonitodux avatar image
0 Votes"
tonitodux answered

Hi,

I am having this looked by our partner IT company, so far

  1.  Click Start, click Run, type regedit, and then click OK.
    
  2.  Locate and then click the following registry subkey:
    

HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Preferences
Note
The x.0 placeholder represents your version of Office (16.0 = Office 2016, 15.0 = Office 2013, 14.0 = Office 2010).
3. On the Edit menu, point to New, and then click DWORD Value.
4. Type DelegateSentItemsStyle, and then press Enter.
5. Right-click DelegateSentItemsStyle, and then click Modify.
6. In the Value data box, type 0, and then click OK.

This worked, but the question is why. Also, in outlook OWA this situation does not happen. I have checked all the rules, read about it on the internet, played with the checkmarks in O354 console but still this looks to me like a bug. I even entered with user credentials on to a test VM just to be sure that her PC did not cause an issue, but on the VM - the same things happened.

Only big change was that we migrated our mailboxes to exchange online.

Cheers

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.