question

slipbits-2359 avatar image
0 Votes"
slipbits-2359 asked DylanZhu-MSFT answered

Visual Studio How can I enable editing tabs?

I was modifying some options int Tools->Options and accidentally turned off all editing tabs. When I press the <tab> button, not space is inserted. I've tried to reset formatting and done other strange and wonderful things but, not tabs. How can I enable tabs?

vs-generalvs-setup
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Castorix31 avatar image
0 Votes"
Castorix31 answered Castorix31 edited

You can check in

Tools
Options
Text Editor


Choose the language (or "All Languages")
then

Tabs

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DylanZhu-MSFT avatar image
0 Votes"
DylanZhu-MSFT answered

Hi slipbits,

You can check if the "smart" has been selected, and "insert spaces" has been enabled.
81781-image.png

In addition, if you are using editconfig file, please check if the indent_size is not zero.
81716-image.png

Best Regards,
Dylan


If the answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



image.png (21.5 KiB)
image.png (28.1 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.