question

$$ANON_USER$$ avatar image
$$ANON_USER$$ asked ·

im trying to get my universal uwp media player to play run dvds but it won't i get a error message im using visual studio community 2019 on windows 10

im trying to get my universal uwp media player to play run dvds but it won't i get a error message im using visual studio community 2019 on windows 10 ![9227-screenshot-23.png][1] ![9249-screenshot-24.png][2] debug output 'Lukes Media Player.exe' (CoreCLR: DefaultDomain): Loaded 'C:\Program Files\WindowsApps\Microsoft.NET.CoreRuntime.1.1_1.1.27004.0_x86_8wekyb3d8bbwe\System.Private.CoreLib.ni.dll'. 'Lukes Media Player.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Users\lferg\source\repos\Lukes Media Player\Lukes Media Player\bin\x86\Debug\AppX\entrypoint\Lukes Media Player.exe'. Symbols loaded. 'Lukes Media Player.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Users\lferg\source\repos\Lukes Media Player\Lukes Media Player\bin\x86\Debug\AppX\System.Runtime.dll'. 'Lukes Media Player.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Program Files\WindowsApps\Microsoft.NET.CoreRuntime.1.1_1.1.27004.0_x86_8wekyb3d8bbwe\mscorlib.ni.dll'. 'Lukes Media Player.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Users\lferg\source\repos\Lukes Media Player\Lukes Media Player\bin\x86\Debug\AppX\WinMetadata\Windows.winmd'. Module was built without symbols. 'Lukes Media Player.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Users\lferg\source\repos\Lukes Media Player\Lukes Media Player\bin\x86\Debug\AppX\System.Runtime.InteropServices.WindowsRuntime.dll'. 'Lukes Media Player.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Users\lferg\source\repos\Lukes Media Player\Lukes Media Player\bin\x86\Debug\AppX\System.Runtime.WindowsRuntime.dll'. 'Lukes Media Player.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Users\lferg\source\repos\Lukes Media Player\Lukes Media Player\bin\x86\Debug\AppX\System.Numerics.Vectors.dll'. 'Lukes Media Player.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Users\lferg\source\repos\Lukes Media Player\Lukes Media Player\bin\x86\Debug\AppX\System.Runtime.WindowsRuntime.UI.Xaml.dll'. 'Lukes Media Player.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Users\lferg\source\repos\Lukes Media Player\Lukes Media Player\bin\x86\Debug\AppX\System.Collections.dll'. 'Lukes Media Player.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Users\lferg\source\repos\Lukes Media Player\Lukes Media Player\bin\x86\Debug\AppX\System.Private.Uri.dll'. 'Lukes Media Player.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Users\lferg\source\repos\Lukes Media Player\Lukes Media Player\bin\x86\Debug\AppX\System.Threading.Tasks.dll'. 'Lukes Media Player.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Users\lferg\source\repos\Lukes Media Player\Lukes Media Player\bin\x86\Debug\AppX\FFmpegInterop.winmd'. Module was built without symbols. Exception thrown: 'System.NullReferenceException' in Lukes Media Player.exe Object reference not set to an instance of an object. ![9217-screenshot-25.png][3] [1]: /answers/storage/attachments/9227-screenshot-23.png [2]: /answers/storage/attachments/9249-screenshot-24.png [3]: /answers/storage/attachments/9217-screenshot-25.png im trying to get my universal uwp media player to play run dvds but it won't i get a error message im using visual studio community 2019 on windows 10 to put onto the Microsoft store here is the demo https://www.youtube.com/watch?v=0TPkyBRQJdk

windows-uwpwindows-uwp-xaml
1 comment
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello, I used the code here to try to reproduce your problem and opened a VOB file. Although it was not successfully decoded, it did not report an error in the place you gave. Can you provide the complete code, or try to use other video files (this step is mainly to confirm whether FFmpegInteropMSS supports VOB format decoding).

0 Votes 0 · ·

0 Answers