question

YueHoAlexLam-8365 avatar image
0 Votes"
YueHoAlexLam-8365 asked YukiSun-MSFT commented

Exchange 2019 CU7 installation issues

Hi,

We are on Exchange 2019 cu6 su6.
When trying to apply CU7 fails with following error:

"The upgrade patch cannot be installed by the windows installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch."

Tried to look for any setup log, but seems the setup couldn't start, and it doesn't have any log to review.

Appreciate any suggestions on troubleshooting this. Million Thanks!

office-exchange-server-administrationoffice-exchange-server-itprooffice-exchange-server-deployment
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

The server was just installed the CU6, and also applied SU6 yesterday without issue.

However, when I try to install the CU7 or CU8, or applying the SU7, it also prompt this error and the installation also failed to start.

Please help. Million Thanks!

0 Votes 0 ·

1 Answer

YukiSun-MSFT avatar image
0 Votes"
YukiSun-MSFT answered YukiSun-MSFT commented

Hi @YueHoAlexLam-8365,

Each CU is a full installation of Exchange that includes updates and changes from all previous CU, so normally you should be able to install CU7 as long as you have an earlier CU of Exchange 2019 installed. Given this, you may try redownloading the CU7 package from Microsoft Volume Licensing Center, then follow the instructions in the article below to install the CU and see how it goes:
Upgrade Exchange to the latest Cumulative Update

Furthermore, Exchange Server 2019 Cumulative Update 9 (KB4602570) has just been released and can be downloaded from both VLSC and the download center. This regularly scheduled cumulative update contains all the security fixes of the security updates in March and other previous security updates. So personally I'd recommend upgrading to the latest CU9 directly for your current situation.

Should the error persists, could you please run the command below to verify the build number of the current installation?

 Get-ExchangeServer | Format-List Name,Edition,AdminDisplayVersion

If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thanks! I have downloaded CU9 and it has been upgraded successful.
While I have skipped CU7 and 8.

As per your info, CU9 should be including all contents so I am not necessary to install CU7 and 8 anymore.

Thanks for your help.

0 Votes 0 ·
YukiSun-MSFT avatar image YukiSun-MSFT YueHoAlexLam-8365 ·

Happy to know that it helped :)

0 Votes 0 ·