question

SubramaniSreeSusmitha-2718 avatar image
0 Votes"
SubramaniSreeSusmitha-2718 asked SubramaniSreeSusmitha-2718 commented

The property 'requireGuestProvisionSignal' is not valid because the 'Microsoft.Compute/Agentless' feature is not enabled for this subscription."

I'm trying to deploy a windows server VM using ARM Template and I have configured the OS progile as below.
"windowsConfiguration": {
"provisionVmAgent": true,
"enableAutomaticUpdates": true,
"patchSettings": {
"patchMode": "AutomaticByOS"
}
},
"secrets": [],
"allowExtensionOperations": true,
"requireGuestProvisionSignal": true


And when i deploy getting the below error.
'requireGuestProvisionSignal' is not valid because the 'Microsoft.Compute/Agentless' feature is not enabled for this subscription

I'm stuck with this error and seeking help.

And I'm trying this using my Visual Studio Subscription

azure-virtual-machinesazure-virtual-machines-extension
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

stan avatar image
1 Vote"
stan answered SubramaniSreeSusmitha-2718 commented

Hi,
remove property "requireGuestProvisionSignal": true or at least set it to false.

from your ARM template deployment and it will probably succeed. This property is probably is used for some feature that is not yet generally available and requires additional setup.

Please "Accept the answer" if the information helped you. This will help us and others in the community as well.


· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello Stan,

I tried the same by setting 'requireGuestProvisionSignal' to false.But ended up with the below error.

"details": [
{
"code": "InvalidParameter",
"message": "The property 'requireGuestProvisionSignal' is not valid because the 'Microsoft.Compute/Agentless' feature is not enabled for this subscription."

}



0 Votes 0 ·
vipullag-MSFT avatar image
0 Votes"
vipullag-MSFT answered SubramaniSreeSusmitha-2718 commented

@SubramaniSreeSusmitha-2718

After some research into the error itself The property 'requireGuestProvisionSignal' is not valid because the 'Microsoft.Compute/Agentless' feature is not enabled for this subscription. I was able to find the following document that references this property.

Unfortunately the documentation here is not very useful to distinguish between what a subscription would require to have in place in order to use some parameters.
I also looked under the Azure resource explorer where you can find the details of the different resource providers and I was able to confirm that there is no Microsoft.Compute/Agentless provider listed even for my own subscription.


81905-vm-issue1.png

81931-vm-issue2.png

I would recommend to remove the property altogether from the template (based on the fact this property is optional) and try again.

Hope this helps.

Please 'Accept as answer' if the provided information is helpful, so that it can help others in the community looking for help on similar topics.





vm-issue1.png (3.7 KiB)
vm-issue2.png (77.1 KiB)
· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

That is what I have suggested already without research :)

0 Votes 0 ·

@stan Thanks for answering this. Looks like we posted the answer at same time :)

1 Vote 1 ·

Hi Vipul,

I tried to remove the property 'requireGuestProvisionSignal' from the template.But ended up with the below error
"code": "VMAgentStatusCommunicationError",
"message": "VM 'myVM1gbitest' has not reported status for VM agent or extensions. Verify that the OS is up and healthy, the VM has a running VM agent, and that it can establish outbound connections to Azure storage


0 Votes 0 ·
stan avatar image stan SubramaniSreeSusmitha-2718 ·

Does the VM has access to Internet. Are you using your own image or some of the images in the marketplace. If you use your own image you will need to install vm agent. More about the VM agent here. You can use the agent or not in your image but if you do not you must specify it in the template.


0 Votes 0 ·

Hello Stan,

 We are using default Windows Server image in azure.I will try installing the vm agent.Thanks!
0 Votes 0 ·