question

FelipeSantosBRA avatar image
0 Votes"
FelipeSantosBRA asked FelipeSantosBRA answered

VMs x Internet x Hyper-V x Win 10 Ultimate 20H2

Boa noite a todos!

Eu preciso de uma ajuda para o problema de navegação na Internet das minhas máquinas virtuais configuradas no Hyper-V no Windows 10 Ultimate 20H2. O que está acontecendo:

Eu estou utilizando o "Default Switch" criado automaticamente durante a instalação do Hyper-V. Pelo que pesquisei, nos clientes Windows compatíveis, não é possível criar outro switch externo para o NAT.

Tanto em máquinas virtuais Windows e Linux, a interface de rede mostra que há conectividade com a Internet. Inclusive, testes de PING e TRACERT são possíveis.

O problema é que a navegação pela Internet através das VMs não é possível. O DHCP está configurado nas VMs e os IPs foram atribuídos com sucesso.

Eu já desabilitei o firewall nas máquinas virtuais, o antivírus e o firewall do host também, mas o problema continua. Também não há qualquer proxy configurado.

Pelo que pesquisei, o problema pode ser o seguinte: as VMs não conseguem reconhecer que, para acessar a Internet, é necessário que o tráfego passe pela placa de rede física do host. Mas se as máquinas estão utilizando a interface "vEthernet (Default Switch)", por que este problema?

Alguém poderia me ajudar com este caso?

Obrigado.







not-supported
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

CandyLuo-MSFT avatar image
0 Votes"
CandyLuo-MSFT answered CandyLuo-MSFT edited

Hi ,

Currently in Microsoft Q&A we only support English, you may reply us in English and we can continue this thread discussing. I have translated it in English:



I need help with the Internet browsing problem of my virtual machines configured on Hyper-V on Windows 10 Ultimate 20H2. What's up:

I am using the "Default Switch" created automatically during the installation of Hyper-V. From what I researched, on compatible Windows clients, it is not possible to create another external switch for NAT.

In both Windows and Linux virtual machines, the network interface shows that there is connectivity to the Internet. In fact, PING and TRACERT tests are possible.

The problem is that browsing the Internet through VMs is not possible. DHCP is configured on the VMs and the IPs have been successfully assigned.

I have already disabled the firewall on the virtual machines, the antivirus and the host firewall as well, but the problem continues. There is also no proxy configured.

From what I researched, the problem may be the following: VMs are unable to recognize that, in order to access the Internet, it is necessary for traffic to pass through the host's physical network card. But if the machines are using the "vEthernet (Default Switch)" interface, why this problem?



Another way to access internet is using internal switch for NAT. The following article talking about how to create a NAT virtual network with internal switch step by step, you could have a look:

Create a NAT virtual network

For default switch has no internet issue, if all the VMs have the same problem, I would suspect the issue is more related with default switch.

One thing you might try is to go into Turn Windows features on or off and remove Hyper-V then, after the required restart, go back in and turn it back on again. This will reinstall Hyper-V and create a new Default Switch. All your VMs will still be there after doing so.

Check if this can solve the problem.

Best Regards,
Candy


If the Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

FelipeSantosBRA avatar image
0 Votes"
FelipeSantosBRA answered FelipeSantosBRA edited

I will be checking that, and will respond. Thank you.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

FelipeSantosBRA avatar image
0 Votes"
FelipeSantosBRA answered CandyLuo-MSFT commented

Did not work! The problem continues. Is it a bug in Windows 10 20H2?

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I was using 20H2 and did not occur such problem. Have you created a NAT network to do a test?

0 Votes 0 ·
FelipeSantosBRA avatar image
0 Votes"
FelipeSantosBRA answered

It's not possible to create a new NAT in Windows 10 20H2 for it is created automatically. From what I researched, "multi-NAT" is only available in Windows Server versions. I will continue to research about this.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.