question

marktt avatar image
0 Votes"
marktt asked marktt answered

Exchange Server Send Connector

Hi ,
We've multiple exchange 2010 and exchange 2016 and running on coexistence mode.
A send connector with domain * and source server 2010.
B Send connector with domain gmail.com and source server 2016.

Mailbox on exchange 2010 will go to exchange 2010 A Send Connector.
Mailbox on exchange 2016 except gmail.com go to exchange 2010 A Send Connector.

After disable A Send Connector, Mailbox on exchange 2010 will receive bounce back.#554 5.4.12 SMTP; Hop count exceeded - possible mail loop detected , it can't route to exchange 2016 B Send connector.

Can we route all the mail traffic to Exchange 2016 B Send connector?

Thanks.

office-exchange-server-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AndyDavid avatar image
0 Votes"
AndyDavid answered

Set the B send connector address space to * and disable send connector A. That will work unless you changed something else.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

marktt avatar image
0 Votes"
marktt answered AndyDavid commented

anonymous userDavid Yes, I've try to config B connector with * and disable send connect A, it can't route correctly, so I'm confuse with the connector.
Any exchange site configuration need to take care?

Thanks.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

That should work out of the box. Is there another connector somewhere that is routing back to that server or a smart host?

What does message tracking show?

0 Votes 0 ·
marktt avatar image
0 Votes"
marktt answered marktt commented

anonymous userDavid It say 2016 server reject the message with 554 5.4.12 SMTP; Hop count exceeded - possible mail loop detected on message id .

If i put
A Connector with domain Exchange 2010
B Connector with
domain Exchange 2016

It will use Exchange 2010 first and never go to Exchange 2016.

Thanks.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Not sure what you mean by all that. Can you post an output of :

 get-sendconnector  |FL 

Does this happen will all messages you send externally?


0 Votes 0 ·

I can see message tracking, it say Last error: A local group was detected. and stuck on the message queue.

Thanks.

0 Votes 0 ·
ZhengqiLou-MSFT avatar image
0 Votes"
ZhengqiLou-MSFT answered

Hi @marktt ,

I think this is because of a setting error of your send connector or Exchange server.
Is the domain of your recipient configured as an authoritative accepted domain?
See this thread: https://social.technet.microsoft.com/Forums/office/en-US/8eb458ae-42e9-4aba-a181-4ffaf627c3e8/last-error-a-local-loop-was-detected-exchange-2010-linux-postfix?forum=exchangesvrsecuremessaging

About the error: Hop count exceeded - possible mail loop detected, please check this:
82175-image.png

Regards,
Lou


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


image.png (30.6 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

marktt avatar image
0 Votes"
marktt answered ZhengqiLou-MSFT commented

Hi @ZhengqiLou-MSFT
I send to gmail or outlook.com.
Does it relate to cost? exchange 2010 is and cost 1 and exchange 2016 is cost 10.
But I was disable exchange 2010 rule, it shouldn't relate to cost?

Thanks.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I'm still waiting on all the other questions I asked earlier. We cant help you unless you provide that information.
Cost is not relevant here.

0 Votes 0 ·

Hi @marktt ,

No, as you said, you have only two send connectors right?
Then after you disabled one, it will use the another one to route emails whatever the cost is. Even though Exchange has a default invisible send connector which has the lowest priority.

And like Andy said, you could run the cmdlet in EMS and post the result(covering your personal information) so we could do a better research.

Regards,
Lou

0 Votes 0 ·
marktt avatar image
1 Vote"
marktt answered

anonymous userDavid @ZhengqiLou-MSFT The environment too complex , let me take more time to study.
Thanks for your help.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.