question

Said-8909 avatar image
0 Votes"
Said-8909 asked TravisCragg-MSFT answered

Black screen when I try to manage VM via Bastion

Hi Team,


We created 4 VM instances in Azure within the same subnet (different AZs) and for a security reason, we manage the linux instances via bastion (SSH), What we noticed is that we keep losing the access to VMs (black screen with white square flashing cursor) after 1 hour time of its creation.

I want to emphasize that the VM are still providing services (VPN, TACACS/Mavis..etc) while we still do not have access to VM.

Help will be much appreciated.
Said

azure-bastion
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

TomasKadlec-4238 avatar image
0 Votes"
TomasKadlec-4238 answered

Hi @TravisCragg-MSFT ,


can you please help us with this one? Thank you


BR Tomas


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

TravisCragg-MSFT avatar image
0 Votes"
TravisCragg-MSFT answered

This is strange. These can be difficult to troubleshoot, as there are 2 parts that could be having an issue: Azure Bastion & the VM. Azure Bastion typically just translates protocol in these cases.

To start, figure out where the issue is coming from by removing Azure Bastion from the scenario. The best way to do this is to connect to the VM via SSH outside of Bastion, typically via another VM in the VNET, or by attaching a Public IP to the VM. Once connected, see if the issue persists after waiting an hour.

If the issue is with the VM, here is a great doc that outlines common SSH errors to a Linux VM. If the issue is only with Azure Bastion, your best bet is to create a support request.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.