question

yzgoa-2983 avatar image
0 Votes"
yzgoa-2983 asked jiayaozhu-MSFT answered

How to adjust virtual machine display resolution to adapt to full screen

I've used VirtualBox before, and am new to Hyper-V.

On my Win10 desktop, I've installed a virtual machine of CentOS, and hope to make its display resolution fully utilize my hardware capacity (1920 x 1080).

For Hyper-V,
- in context of "Hyper-V Manager > host > Hyper-V Settings > Enhanced Session Mode", I've checked the box of "Use enhanced session mode";
- in context of "Hyper-V Manager > vm > Settings > Integration Services", I've checked all the boxes, including "Guest services".

When I maximize the connection, the window maximizes to full screen but the guest operating system reminds at lower resolution as "1152 x 864 (4:3)", and that was the only option in the Linux context of "root user > Taskbar > Applications > System Tools > Settings > Devices > Displays".

I hope to make the guest Linux operating system adapt to full screen display resolution, and any pointers will be highly appreciated.

Please also let me know if you need additional information.

windows-server-hyper-v
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

From your description, we find the issue is related to Hyper-v, I would remove the tag of "msc-virtual-machine-manager-hyper-v", which represents deploying Hyper-v in SCVMM. And add the tag "windows-server-hyper-v" for you. Thanks!

1 Vote 1 ·
jiayaozhu-MSFT avatar image
0 Votes"
jiayaozhu-MSFT answered yzgoa-2983 edited

Hi,

Thank you for your posting!

Based on your descriptions, first I would like to explain your issue:

"1152 x 864 (4:3)" is the default screen resolution and the way that you have tried: "root user > Taskbar > Applications > System Tools > Settings > Devices > Displays" is for Ubuntu Hyper-V guests and is not suitable for CentOS and Red Hat VMs.

In this case, you can use the grubby tool to change your screen resolution in CentOS to the biggest size that you want. You can follow the steps in the video to setup:

https://www.netometer.com/blog/?p=1663

(Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.)

Thank you for your time!

Best regards
Joann


If the Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thank you for your help.

I followed the below link, and called command grubby --update-kernel=ALL --args="video=hyperv_fb:1920x1080"; but it doesn't work.
https://www.netometer.com/blog/?p=1663

After reboot, the virtual machine will stuck forever at start with a black screen, and eventually I had to power cycle the virtual machine, and boot into rescue mode by choosing "CentOS Linux (0-rescure-xxx...) 7 Core" from the boot menu.

I used command grabby again and changed display resolution back to the original default value (1152x864), and the virtual machine recovered to normal.

I'm wondering, did I miss anything in the steps here? Any hints will be highly appreciated.


0 Votes 0 ·
jiayaozhu-MSFT avatar image
2 Votes"
jiayaozhu-MSFT answered yz-goa edited

Hi,

Thank you for your reply!

After my research, the grubby command may only work for a few screen resolution. Based on your descriptions, your failure to use this command is related to the poor support from your driver for your graphics card. I suggest you can first try to open up a huge of resolutions for your graphics card. The article below is suitable for Centos 7:

https://superuser.com/questions/750382/how-to-change-resolution-of-centos-6-5-resolution-on-virtualbox-host-win7

(Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.)

Secondly, you can try some other solutions to solve your issue. Here are some methods you can try:

1)Reinstalled the system in a fresh VM, and re-applying the grubby command

2)To install xrdp and use remote desktop. See article:

https://www.itzgeek.com/how-tos/linux/centos-how-tos/install-xrdp-on-centos-7-rhel-7.html

(Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.)

More information you can find:
https://superuser.com/questions/1118192/updating-the-screen-resolution-in-centos7-in-hyper-v

(Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.)

If you still cannot maximize your resolution, I guess you may have to change your drive which can better support your graphics card. And you can ask your retailer for this information.

Thank you for your support!

Best regards
Joann


If the Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.