question

MichaelAdams-5874 avatar image
0 Votes"
MichaelAdams-5874 asked erinding-msft answered

OneDrive Files Activate Protected View in Word and Excel

I have a customer computer where any Word or Excel file open from the user's OneDrive for Business folder is opened in Protected View. I adjusted settings in Protected View, and unchecking "Enable Protected View for files originating from the internet". I really don't want to leave that unchecked.

I also tried adding the OneDrive folder to "Trusted Locations", and that did not correct the issue.

Any help would be appreciated.

office-excel-itprooffice-word-itprooffice-onedrive-client-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JohnKorchok avatar image
0 Votes"
JohnKorchok answered

Personally, I believe that protected view is there to protect Microsoft from legal action, not to help the user. I uncheck all three options all all our installations. Those setting don't exist in any other version of Word, so they hardly seem vital.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

erinding-msft avatar image
0 Votes"
erinding-msft answered erinding-msft commented

Hi @MichaelAdams-5874,

I have a customer computer where any Word or Excel file open from the user's OneDrive for Business folder is opened in Protected View.

<< Is the Word or Excel file in your own OneDrive folder or a folder shared by others?

I also tried adding the OneDrive folder to "Trusted Locations", and that did not correct the issue.

<< If you added the folder on the network to “Trusted Locations”, please check the Allow Trusted Locations on my network option to have a check.
84709-1.png

Besides, are there any codes or macros in the files?
You could try to create a blank file to check the issue.

Any updates, you could post back.

If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


1.png (5.5 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@MichaelAdams-5874
How is your issue going now?
Any updates, please let me know.

0 Votes 0 ·
MichaelAdams-5874 avatar image
0 Votes"
MichaelAdams-5874 answered

To answer some questions on some of the details. The issue only occurs when the file is in the OneDrive folder. If the file is somewhere else on the local disk, the error does not occur.

The "Allow Trusted Locations on my network" setting is checked.

The files do not have macros.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

erinding-msft avatar image
0 Votes"
erinding-msft answered

@MichaelAdams-5874

Thanks for your reply.

  1. Is there any prompt of Protected View? Please provide a screenshot of it if yes.

  2. Is the Word or Excel file in your own OneDrive folder or other user's OneDrive shared folder?

You could try the following.
For Word: press Win + R, type gpedit.msc in Run box, Enter to open Group Policy Editor.
Navigate to User Configuration>Administrative Templates>Microsoft Word 2016>Word Options>Security>Trust Center>Protected View to enable Do not open files in unsafe locations in Protected View to check the issue.
Configuration of Excel in Group Policy is similar to Word.


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.