question

BKITStaff-2336 avatar image
0 Votes"
BKITStaff-2336 asked ZhengqiLou-MSFT commented

Exchange 2013 and 2010 coexistence - OWA Premium UI touch layout does not automatically load on mobile devices

Hi MS Q&A experts, as an interim migration step, that will last at least for an year, I have an Exchange 2010 server co-existing with an Exchange 2013. Both fully updated with latest Windows and Exchange updates. After moving the DNS namespace to the new Exchange 2013 CAS I was doing some tests with a test mailbox named "xch2013setup" placed on the xch2013 Mailbox DB. I still haven't moved the arbitration mailboxes to xch2013.

Mailflow (internal and external) is ok. Proxying between Exchange servers is ok. Opening Outlook client or OWA, from a Windows notebook, with the xch2013setup account, correctly connects to 2013 CAS. OWA from the notebook loads the OWA 2013 Premium UI in desktop mode. Connecting to a mailbox residing on Exchange 2010, correctly loads the meant mailbox, and, regarding owa, I'm presented with the owa 2013 login page and, once logged in, I'm proxied to Exchange 2010 OWA. Then, all seems to work flawlessy.

However, if I try to open the same mailbox from, for example, an iPad or an Android smartphone (tried with some newer and older OS versions), I'm presented with the OWA Premium UI for mouse layout with IOS and the Light layout version (html4) with Android. If, from the same devices, I enter in the browser address bar "https://<Exchange2013CASURL>/owa/?Layout=tWide" (or tNarrow) it loads the correct Premium UI touch optimized layout.

I know Exchange 2013 is in extended support phase and maybe I cannot pretend too much (even if a supported solution should work as expected I think, like it is proudly said here), but I wanted to know if the behavior is related to the 2013 server side OWA app that is aging, if it's a coexistence problem, or just a matter of an OWA virtual directory setting...

Thanks for your help.
Regards,
Francesco B. B.


office-exchange-server-administrationoffice-exchange-server-deployment
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ZhengqiLou-MSFT avatar image
1 Vote"
ZhengqiLou-MSFT answered

Hi @BKITStaff-2336 ,

Thank you so much for sharing these information, and sorry that I don't have a suitable environment to test the iPad device with the Ex 2013 server.

I tested the iPhone and Android smartphones with the Exchange 2016 CU20 OWA and they both show the Premium UI( as ?Layout=tNarrow and it's same with tmouse ).

So far I've seen four types of OWA:
1. Desktop Premium
2. Desktop Light
3. Mobile tNarrow and tMouse(I think this is for smartphones)
4. Mobile tWide( this type could be used for tablets I guess)

Narrow(by default):
86079-narrow.jpg
Wide:
86064-wide.jpg

I'm not sure as you said the iPad will load as the desktop view but not a mobile view, is that the case? And if you could, when using the Android device, try changing the light version to Premium like the desktop?

It is also a good idea, if you don't mind installing a fresh Exchange 2013 CU23 and test if this could work.

Best regards,
Lou


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


narrow.jpg (30.9 KiB)
wide.jpg (38.3 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ZhengqiLou-MSFT avatar image
0 Votes"
ZhengqiLou-MSFT answered ZhengqiLou-MSFT edited

Hi @BKITStaff-2336 ,

Here are what I understand, please check if these are right:
1. For the second paragraph, you did the tests with a Ex 2010 mailbox and Ex 2013 OWA URL. If so, then the result is expected.
2. Then you tried to open mobile OWA from IOS/Android with the "xch2013setup" mailbox, in this case both these terminals should show the OWA 2013 Premium UI. But the Android gave you the Light view.
If there are something wrong please let me know.

I think you could do the following tests to target the issue:
1. Use another browser like Edge/Chrome/Firefox...
2. Compare the URL suffix after you logging in to OWA, and see if it's redirecting to a different URL.
3. Try logging in to the desktop OWA to see if it's in the Light version.

Sorry that I couldn't give you an exact solution for this issue with so many things unclear, and I think the Android system could also be a reason and that is out of our range.

Best regards,
Lou


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

BKITStaff-2336 avatar image
0 Votes"
BKITStaff-2336 answered BKITStaff-2336 edited

Hi @ZhengqiLou-MSFT ,

  1. In short, I'm saying that, by using a Windows notebook, either I use OWA or Outlook full client to either connect to a mailbox residing on Exchange 2010 or on Exchange 2013, it correctly takes me to the right place with, regarding OWA, the right user interface. As expected.

  2. Correct regarding Android (tried both with android os versions 10 and 6). Regarding IOS, instead, it loads the owa premium UI, but in desktop mode (like as appending "?layout=tmouse" in the URL). To force the expected touch optimized layout I must manually append "?layout=tnarrow|twide" to the URL.

Regarding the tests you suggest me to perform:
1. On Android I already tried with Firefox, Chrome and Edge browser apps. Same behavior. Hint: if from within the browser app I switch to "desktop mode", all the browsers correcly load the Premium UI optimized for desktops.
2. Nope, it just appends something like "path#mail". Nothing else.
3. It correctly loads Premium UI in desktop mode if I use a desktop device (notebook or pc).

Concluding, it seems to me that OWA app (server side) isn't able to understand whether I'm using a mobile or a desktop device, either that I use IOS or Android. The only difference is that in the case of IOS it loads the Premium UI in desktop mode, whereas with Android it loads the light html4 version.

It would be cool if, like it happens on many web sites, the layout automatically changes to touch optimized or desktop optimized basing on the device is being used to browse the web site...
I'm wondering if this will be achievable at least with newer on premise Exchange servers versions...

Thank you,
Francesco B. B.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

BKITStaff-2336 avatar image
0 Votes"
BKITStaff-2336 answered ZhengqiLou-MSFT commented

Ok, you just did confirm my thoughts. Newer Exchange versions work just fine and better with mobile devices.

My Exchange 2013 is already a CU23 and a fresh install.

IPad does load the owa desktop version, in fact, touch buttons are missing in the bottom part of the interface.

Android devices, if are told to load the "desktop" version of the owa site, as I told in my previus post, they correcly load the Premium UI in desktop mode.

Moreover I have got a reply on StackExchange in which, basically, is told that Owa 2013 has compatibility issues with Android devices. (Here the link)

I hope to be able to migrate as soon as possible my Exchange infrastructure to, at least, 2019 version. In the meanwhile I will tell my roaming OWA users to use the trailing "?Layout=tnarrow" in the OWA URL when using mobile devices.

Thank you for the help.
Francesco B. B.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @BKITStaff-2336 ,

Very happy to know you have found the reason.
And it's my honor to working on an issue with you, many thanks for your patience and kindness.

Have a good day!

Best regards,
Lou

0 Votes 0 ·