question

Peter-1728 avatar image
0 Votes"
Peter-1728 asked Phil-3480 edited

RDP protocol error code 0x112f

Hi,
I have several computers, one is my main computer (windows 10 home), with two monitors. The other computers are in a seperate room, without monitors.
Since a few weeks, when I try to connect to one of my other computers using RDP, I get a protocol error code 0x112f when I use the option "Use all monitors for remote session". Several years before it worked fine.... And another computer is still working fine with 2 monitors....

Can you please help? It is possible that it is caused by an update on my remote computer.

Thanks!
Peter.

remote-desktop-client
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

My remote computer is on Windows 10 Pro

0 Votes 0 ·

I am also facing the same issue, suddenly cannot use all monitors for remote session

0 Votes 0 ·
LeilaKong-MSFT avatar image
0 Votes"
LeilaKong-MSFT answered Peter-1728 commented

Hello @Peter-1728 ,

Please try to use the group policy editor (Local Computer Policy\Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment. Then disable “Use the hardware default graphics adapter for all Remote Desktop Services sessions”).

Link: https://answers.microsoft.com/en-us/windows/forum/all/windows10-updates-rd-dual-monitor-and-last-opened/bdf97e6e-039b-4d85-aa05-3cc69b863394


Best regards,
Leila


If the Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello Leila,

Thanks for your response! I've changed the group policy setting on both the host and the remote computer, but it still doesn't work when i try to connect to dual monitor... Still getting the protocol error code 0x112f. Unfortunately..

Best regards,
Peter.

0 Votes 0 ·
LeilaKong-MSFT avatar image
0 Votes"
LeilaKong-MSFT answered

Hello @Peter-1728 ,

I am currently performing research on this issue and will get back to you as soon as possible. Your patience is highly appreciated.
If you have any updates during this process, please feel free to let me know.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LeilaKong-MSFT avatar image
0 Votes"
LeilaKong-MSFT answered LeilaKong-MSFT commented

Hello @Peter-1728 ,

Is there any update on your side? You may also open a ticket to Microsoft for further professional help:
https://support.microsoft.com/en-us/help/4341255/support-for-busines

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello Leila,

No updates from my side. Unfortenately still working with only 1 screen. I will open a ticket, thanks for your help.

0 Votes 0 ·

Hello @Peter-1728 ,

Thanks for your response and cooperation. Any sharing of progress is highly appreciated.

0 Votes 0 ·
Peter-1728 avatar image
0 Votes"
Peter-1728 answered LeilaKong-MSFT commented

The problem is solved! I have connected a physical monitor to the computer that I try to connect to. And changed the resolution. Now I am able to use 2 monitors again.
Regards,
Peter.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello @Peter-1728 ,

Many thanks for your update, well done!

0 Votes 0 ·
Phil-3480 avatar image
0 Votes"
Phil-3480 answered Phil-3480 edited

Rebooting the PC I was RDCing onto solved the problem for me

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

....on 1st connect only !!!

After that the problem's back again ;(

Found another workaround....

  1. Go into Display settings & change 'Multiple displays' to 'Show only 1' or 'Show only 2', whichever you prefer

  2. RDC with 'Use all monitors for the remote session' checked

  3. Minimise the RDC session, go back into Display settings & change 'Multiple displays' back to 'Extend these displays'

  4. Now maximize your RDC session & all should be well ;)



0 Votes 0 ·