question

emilymcalister avatar image
0 Votes"
emilymcalister asked ·

Can't access web service running on VM

Hi,

I've set up a demo Splunk deployment in Azure for training purposes, using some Virtual Machine resources. I've installed the application successfully (and it is running), however can't seem to access the web ui from my laptop using the public IP address (HTTP, port 8000).

I've added inbound rules for the port and confirmed connectivity using ping. The port is listening.

Unsure what other troubleshooting to do from here - any advice/suggestions welcome.

Thankyou in advance.

azure-virtual-machines
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

bedge avatar image
1 Vote"
bedge answered ·

Hi,

I assumed you've already checked the Network Security Group of the subnet that the VM belongs to and since this is a demo environment, try to disable Windows Firewall on the VM and your laptop and see if it works.

· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Yes, checked the Security Group config - all seems fine. Rookie mistake - forgot to turn off the firewall on the VM itself. Solved the issue. Thanks

0 Votes 0 ·
lextm avatar image
0 Votes"
lextm answered ·

Keep in mind there are both Windows Firewall on that VM and an Azure firewall. You have to set inbound rules at both places.


· 1 ·
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Of course! Thankyou! Turned off the firewall on the RHEL Server - all good :)

0 Votes 0 ·