question

MelvishG-4374 avatar image
0 Votes"
MelvishG-4374 asked ESPITGuy-1290 commented

How to permanently diable auto restart for updates on OS level? Windows Server 2016,2019

How can i permanently disable the auto restart when after update have been installed on OS level. Even if there are login users or not, the server should not restart. As the server has been configured on another platform to restart every Sunday. so the deal is that even if updates are install on Monday to Saturday, the server should always remain on pending reboot.

Thanks in advance for you help.




windows-server-2019windows-10-securitywindows-server-2016
· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

IMO, this is the exact reason why you should manage the updates with WSUS, so you can approve and install updates only when you feel comfortable to reboot.


0 Votes 0 ·

Hello,
In fact this is exactly was is been done for the servers. The security and critical updates are managed by the WSUS.
However the last result error code was 0x80240009 and i am still searching for a solution (please advise if you have any).
In the mean time, the patching of the servers are done manually and I don't want them to reboot immediately after installing the patch as I mention in my first question.

0 Votes 0 ·

WU_E_OPERATIONINPROGRESS(0x80240009) means Another conflicting operation was in progress. Some operations such as installation cannot be performed twice simultaneously. Maybe you should try do update cleanup first to remove updates that is superseded by the other updates and see if it fixes your problem.


0 Votes 0 ·
Show more comments
TeemoTang-MSFT avatar image
0 Votes"
TeemoTang-MSFT answered

Enable No auto-restart with logged on users for scheduled automatic updates installations policy in group policy editor
No auto-restart with logged on users for scheduled automatic updates installations prevents automatic restart when a user is signed in. If a user schedules the restart in the update notification, the device will restart at the time the user specifies even if a user is signed in at the time. This policy only applies when Configure Automatic Updates is set to option 4-Auto download and schedule the install.
Source:
https://docs.microsoft.com/en-us/windows/deployment/update/waas-restart#delay-automatic-reboot

Try the Task Scheduler method.
Click Start and type Task Scheduler
Navigate to Task Scheduler Library >> Microsoft >> Windows >> UpdateOchestrator
To disable automatic reboots right-click on Reboot and select disable.
Then be sure change the permissions. Should be set to Read & Execute.

Also, You can try Windows 10 Reboot Blocker:
https://udse.de/reboot-blocker/
A simple Windows-Service that will update this "active hours" timeslot in the background.


If the Answer is helpful, please click "Accept Answer" and upvote it.
The mentioned product is owned and operated by a third party. Microsoft has no control regarding to the product's performance and reliability.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

KapilArya avatar image
0 Votes"
KapilArya answered

Hello,

Try enabling No auto-restart with logged on users for scheduled automatic updates installation policy setting at Computer Configuration -> Administrative Templates -> Windows Components -> Windows Update.

See if it helps you!

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.