question

milolav avatar image
0 Votes"
milolav asked MinhNgcPhan-8059 answered

How to disable Microsoft Edge automatic sign-in on first run?

When you are signed into windows with Microsoft account, starting Microsoft Edge automatically signs you in.
<email> has signed in on this device, so we've also signed you in to Microsoft Edge.
How to disable this behaviour?

Among other things, I don't want debugger profile from VSCode to automatically sign me in, but I do want to have main profile signed in. Since debugger profile created in temp dir, it gets deleted when cleaning temp dir, signing me again on the next run. For example, browser started in debug session shows the following command line:
"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --remote-debugging-port=2015 --no-first-run --no-default-browser-check --user-data-dir="C:\Users\user\AppData\Local\Temp\vscode-edge-debug-userdatadir_2015" --flag-switches-begin --flag-switches-end

As per Edge policy, https://docs.microsoft.com/en-us/deployedge/microsoft-edge-policies#browsersignin if I disable sign in, I won't be able to use it on my main profile.

So, how to run msedge.exe without automatic sign-in? Is there a switch, a policy or something that will disable it? Can it be disabled by default when --user-data-dir switch is present?

ms-edge
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @milolav
I don't find related Edge setting or gpo, I think it's controlled by Windows account settings not Edge settings.
You can open Windows Settings and click Accounts, then click Email & accounts.
On this panel, you can see your Microsoft account. Now you can click on the account and check if you can edit the option of your Microsoft account. If you don't want other apps to use this account, I think you can change the option to Apps need to ask me to use this account.
Besides, you can also check this policy to see if it can achieve what you want: Block all consumer Microsoft account user authentication.

93581-1.png

1 Vote 1 ·
1.png (227.7 KiB)

Hi @YuZhou-MSFT,

Unfortunately I don't have this option in settings.

93732-ss20210504-215117.png

Blocking all consumer Microsoft app auth is also not something I want.

Is there really no option to disable a single instance of Edge browser from automatically signing you in when it starts for the first time?

Can you add that option?

//EDIT:
In addition to having you signed in, it also pins itself to taskbar, why is that?


0 Votes 0 ·
YuZhou-MSFT avatar image
0 Votes"
YuZhou-MSFT answered YuZhou-MSFT edited

Hi @milolav

You don't have that option maybe because the Microsoft account is the main account you use to sign in the computer and the main account will allow all apps to sign in. Only if you can set that option then you can avoid Edge automatically signing in with Microsoft account.

As far as I know, there's no option to disable only Edge from automatically signing with Microsoft account. I also click the Manage button of the account to see if there's any settings, but I find no. Besides, in the description of HideFirstRunExperience policy, it says:

The user will still be automatically signed into Microsoft Edge if the Windows account is of Azure AD or MSA type.

So I think it's by design that Edge will automatically signing with Microsoft account if you log in Windows with Microsoft account.

About pining Edge to taskbar, that's the default behavior of Edge browser. Even if Edge doesn't automatically sign you in, it will also pin itself to taskbar. If you don't like the feature of Edge or have some suggestions about Edge, I suggest you can provide your feedback using Alt+Shift+I in Edge.

If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

Regards,
Yu Zhou

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @YuZhou-MSFT

Only if you can set that option then you can avoid Edge automatically signing in with Microsoft account.

How to do that? Can you provide a registry key, settings location or something that will allow me to set this value even though I don't see it in settings? Or configuration how to get this option visible in settings?

I don't think automatic sign-in and pinning items to user's taskbar without approval is appropriate "default" behaviour. Is there any planned changes to fix that?

Funny enough, latest edge version, 90.0.818.51, breaks relative --user-data-dir folders. This worked in previous versions:
%ProgramFiles(x86)%\Microsoft\Edge\Application\msedge.exe --no-default-browser-check --no-first-run --enable-extensions --bookmark-menu --user-data-dir="TestProfile1"

While now it throws an error
![ss1](/answers/storage/attachments/94799-ss1.png)

Setting --user-data-dir="C:\Testing\TestProfile1" works fine

0 Votes 0 ·
ss1.png (4.4 KiB)

Hi @milolav
I can totally understand how you feel. But if you're signing in Windows with a Microsoft account, I'm afraid that you can't set that option. You can also refer to this thread which has the similar issue.

I have no idea about planned changes to fix that. You can provide your feedback to Edge and Windows. Thanks for your understanding.

0 Votes 0 ·

Hi @YuZhou-MSFT

Linked thread doesn't provide any answer other than generic "not available", and feedback will probably end up on a list that nobody reads let alone acts upon it. Feel free to provide feedback on my behalf if you think it will make a difference.

So, the official Microsoft answer would be don't use Microsoft account or don't use Edge browser if you want to avoid forced automatic sign in?

0 Votes 0 ·
Show more comments
milolav avatar image
0 Votes"
milolav answered milolav published

Hi @YuZhou-MSFT

Only if you can set that option then you can avoid Edge automatically signing in with Microsoft account.

How to do that? Can you provide a registry key, settings location or something that will allow me to set this value even though I don't see it in settings? Or configuration how to get this option visible in settings?

I don't think automatic sign-in and pinning items to user's taskbar without approval is appropriate "default" behaviour. Is there any planned changes to fix that?

Funny enough, latest edge version, 90.0.818.51, breaks relative --user-data-dir folders. This worked in previous versions:
%ProgramFiles(x86)%\Microsoft\Edge\Application\msedge.exe --no-default-browser-check --no-first-run --enable-extensions --bookmark-menu --user-data-dir="TestProfile1"

While now it throws an error
94845-ss1.png

Setting --user-data-dir="C:\Testing\TestProfile1" works fine



ss1.png (4.4 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MinhNgcPhan-8059 avatar image
0 Votes"
MinhNgcPhan-8059 answered

Try going to Settings/Profiles
/ Profile preferences/Allow single sign-on for work or school sites using this profile and disable that setting.
I hope it helps.

135894-image.png



image.png (73.0 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.