question

BitSmithy-4663 avatar image
0 Votes"
BitSmithy-4663 asked ·

Test App is blocking on Splash Screen

Hello,


I have an app in Win Store, now I am preparing the new version on developing laptop.
The new version works in Visual studio in run mode.
Visual studio creates store package and tests it without any error.
Next i publish the app as flayout package.
The package installs from store on my test laptop without visible errors.
But where I run the package on testing laptop, the app blocks on Splash Screen.

How to fix such problem?

windows-uwp
· 4
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@BitSmithy-4663 My suggestion is that you could use the Visual Studio App Center to capture the detailed error messages when you run this app. In addition, you could test this app on other computers and other operation system to check whether this error also happens, if it doesn’t occur on other computers, the error might be related to your computer. There is also a possibility that your anti-virus cause this issue, so you could disable it temporarily and test it again.

0 Votes 0 ·

I tried on other device. Result is the same.
I explored Events Viewer, and I found some info there.

Installation Failure: Windows failed to install the following update with error 0x80073D02

In other event I found:
Event Name: MoAppHang

Here is a full story of my problem.
I had an app in win store, ver. 46.
Next, a new ver. of VS appeared.
I upgraded the VS, and raised nugets, target and minimal version for the app.
Next I tried to RUN source codes
After running unhandled exception become to appear.
I couldnt solve this problem, so I created a new app with the same name and code.
After that operation all become to work.
Next, I made some changes in code, joined the new app with windows store, got store certificate, and raised the app version to 47.
Next I sucessfully created package.
Next I put the app to the store and published it as flayout package.
Now The flayout package can be got from the store, but when i execute my app it hangs on the splash screen.

0 Votes 0 ·

I solved the problem.

In the old version of my app, I had set default language as en and resource folder named as en too.
In the new version of may app I had set default language as en-us and resource folder named as en-us. This change was intended, beacuse I want to change default language of my app.

When I changed default language of the new version to en, app stoped hanging.


Is change of default language between app versions not allowed?

0 Votes 0 ·
Show more comments

0 Answers