question

DeannaDelapasse-9413 avatar image
0 Votes"
DeannaDelapasse-9413 asked ·

Stop azure deployed time triggered webjob

I've read that the "proper" (debatable) way to stop a scheduled webjob is to get to scm and delete the settings.job file. However, my project is deployed as a zip through devops so I can't delete files. Trying gives 409.

I also can't delete the job. Portal tells me it's deleted, but it's not.

I've tried stopping the app service but the jobs keep running. What are the other options?


azure-webappsazure-webapps-webjobs
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

xequence avatar image
0 Votes"
xequence answered ·

Adding an Application settings value of WEBJOB_STOPPED with a value of 1 to stop the job. Here is a reference article for webjobs, https://docs.microsoft.com/en-us/azure/app-service/webjobs-create

Hope this helps and don't forget to mark answer if it helped you!

· 2 · Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@DeannaDelapasse-9413, Just checking in to see if the above post helped answer your question. Kindly let us know if you have any further questions on this specific topic, we would be more than happy to assist you.
Please do mark the post which was helpful by clicking on ‘Accept Answer’ & ‘Up-Vote’ to help the community find the right answers.

0 Votes 0 ·

@xequence @ajkuma-MSFT It doesn't seem modifying the portal app settings during a run effects the running process. I also tried setting WEBJOBS_DISABLE_SCHEDULE but that one didn't help either.

I have one app service with 3 webjobs (1 continuous and 2 triggered).

0 Votes 0 ·