question

LarryMarshall-6578 avatar image
0 Votes"
LarryMarshall-6578 asked ·

create-react-app/fullstack showing 'Hey, Node developers!'

I have followed a couple of threads about deploying a cra app. None have worked. Any change I've made displays the 'Hey, Node developers!' page.

I ran 'npm run build' and ftp-ed the static folder to /site/wwwroot/. I also tried the following file, web.config, in the wwwroot folder.



The structure of the project is

build/
package.json
public/
server/
sql/
src/
I started the project with create-react-app and added an a Node Express server at the server directory. The server is proxied via the proxy key in package.json

Both the src and server folders contain index.js files. Each index.js file starts on its own unique port. The server makes SQL calls to an MSSQL database. I have managed to sync the in-house db to the Azure DB.

Any ideas on what I might try?

azure-webapps
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

ryanchill avatar image
1 Vote"
ryanchill answered ·

Hi @LarryMarshall-6578 make sure you've configured your npm start command under Configuration - General Settings. Let me know if this doesn't help.

alt text



· Share
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.