question

AdminAS-2566 avatar image
0 Votes"
AdminAS-2566 asked OliverFarthing-0611 commented

Web App not opening in IpadOS - "Action not allowed - Organization does not allow you to open this data here"

I am deploying a simple web app to production level IPads in my company. We have had very mixed results on whether it will open or not. We do have the Edge browser installed on the IPad so they can have a similar experience with the IPad's and computers in the area. They are not signed into with enterprise emails or apple ID's they are managed by device. The app itself gets installed on the device but has no function. Here is what happens.

If i install it WITHOUT checking the "open in managed browser" I am met with a 'click' and nothing happens.
If install it WITH checking the "open in managed browser" i am met with the message i pasted above, " Action not allowed - Your Organization does not allow you to open this data here" .
If I am on an IPad with IOS 14 or higher i can have the users long hold and "share to browser" this will open the app. It is also not what should be happening and we have IPad's that will not go that high in IOS. So not a work around.

I have looked into ALL the policies on the tenant. We do not have any compliance policies applied, the profile does not block OR allow this type of data movement. ( i figure it is similar to Android's work profile data movement) I looked into all the other app and device configurations. We either do not have them applied or it does not mention this as an issue.

Can someone please give me some advice. This is literally the simpliest request to work and it doesn't. It doesnt let me open a webpage... weird.

mem-intune-general
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Was this ever fixed i am having the same issue?

0 Votes 0 ·
JarvisSun-MSFT avatar image
0 Votes"
JarvisSun-MSFT answered JarvisSun-MSFT commented

@AdminAS-2566 Thanks for posting in our Q&A. From your description, I noticed that we have no compliance policies applied and if we choose to install it without checking "open in managed browser", we received error messages. If there is any misunderstanding, please feel free to let us know.
For our issue, it is better to check if there are any app protection policies assigned to related users or devices.
https://docs.microsoft.com/en-us/mem/intune/apps/app-protection-policy#benefits-of-using-app-protection-policies

Hope it can help



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I looked into this. I do not have any app protection policies. I would prefer to get this system setup now, then we can worry about what we lock down. Do you have any other suggestions?

Also, to clarify you are correct on your assumption. We set the web app to open as managed browser and I get that error message mentioned. If we select it to NOT open with a managed browser, nothing happens it just selects and does nothing. We have a managed Edge browser on the IPads if that helps.

0 Votes 0 ·

@AdminAS-2566 Thanks for your reply.
Given this strange situation, we do not have the appropriate environment to reproduce your problem. It is better to create an online support ticket to handle this issue more effectively. It is free. Here is the online support link and hope our problem will be fixed as soon as possible.
https://docs.microsoft.com/en-us/mem/intune/fundamentals/get-support

0 Votes 0 ·
RahulJindal-2267 avatar image
0 Votes"
RahulJindal-2267 answered RahulJindal-2267 commented

You won’t receive the restrictive message if you don’t have APP assigned. Are you sure you don’t have any protection policies set? You can verify in the troubleshooting section in MEM to confirm.

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I was thinking the same thing @RahulJindal-2267 , I have tried to look through all my sections and they don't even exist. I am applying this based off of device, not user so not sure if the troubleshooter will work for me. Can you clarify that ?

0 Votes 0 ·

But you will still be having a user sign into company portal app right? Also with regards to this statement- ‘ If I am on an IPad with IOS 14 or higher i can have the users long hold and "share to browser" this will open the app’, which browser does the webapp open in? What is the webapp doing? Are you authenticating on it?

0 Votes 0 ·

There will be no user signing in on that IPad's. They are "shared" ipads on our production floor. Technically the service MSoft is trying to provide by using Device licensing and we are implying to use a weblink (very simple) you would assume you wouldn't need a user to sign in. Technically a user may need to sign into the provided webpage, the device should not need a separate user.

As for the second question: I have removed Safari from the IPad, so I can choose edge and it works fine. That process isn't universal though, as i referenced the IOS versions, so that wouldn't be a prper work around for all my devices.

0 Votes 0 ·
Show more comments