question

MirzaDobric-2745 avatar image
1 Vote"
MirzaDobric-2745 asked JorgeCastro-0107 commented

[Xamarin Profiler] Runtime installed on device is too old on every Android emulator

I'm using VS 2019 version 8.9.10 (build 4) on a Mac with Xamarin Profiler 1.6.15.68. I am getting the "Runtime installed on device is too old" error when trying to profile every Android emulator I have tried so far. I have tried the following emulator images:

  • Android 8.0 (API 26) x86_64 with Google APIs

  • Android 8.1 (API 27) x86_64

  • Android 9.0 (API 28) x86_64 with Google Play

  • Android 10.0 (API 29) x86_64 with Google APIs

  • Android 11.0 (API 30) x86_64 with Google APIs

Profiling also failed with the same message on this physical device:

  • Motorola G7 Power running Android 10 (API 29)


I was able to profile on these devices:

  • Samsung Galaxy S9+; Android 10 (API 29)

  • Nexus 6P; Android 8.1 (API 27)


What is going on here? Is it possible to profile on an Android emulator? If yes, which ones? How can I tell which Android physical devices can be profiled? This product is way too expensive for it to simply not work on emulators and some devices without spelling out exactly why it doesn't work. I expect more for the $6000/year for the Enterprise subscription that's required to use this tool.





dotnet-xamarinforms
· 7
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @MirzaDobric-2745 ,without the profiler/android logs, it's hard to know what's going on, so can you please provide those? The profiler logs can be accessed via Help->Open log directory, and for Android logs, the contents of the Console tab contain them.

0 Votes 0 ·

@JessieZhang-2116 sure thing, I'll get you the logs. I should have them in a few hours.

0 Votes 0 ·

@JessieZhang-2116 I have attached the emulator logs. Let me know if I can provide any other information.

0 Votes 0 ·

@JessieZhang-2116 Here are the Visual Studio logs. Visual Studio only has the deployment logs and those don't really show much. I tried attaching the captured logcat files but for some reason this page won't let me upload those files. I keep getting an error saying "No such upload". I will post those to pastebin and post the links here.

Emulators:
Android 8.0 (API 26) x86_64 with Google APIs
103067-android-deploy-pixel-2-oreo-8-0-api-26.log

Android 8.1 (API 27) x86_64
103106-android-deploy-api27-x86-64.log

Android 9.0 (API 28) x86_64 with Google Play
103030-android-deploy-api28-x86-64-playstore.log

Android 10.0 (API 29) x86_64 with Google APIs
103121-android-deploy-pixel-2-q-10-0-api-29.log

Android 11.0 (API 30) x86_64 with Google APIs
103086-android-deploy-api30-x86-64-play.log


0 Votes 0 ·

This is a known issue reported here , but it was closed due to the lower priority.

You can report this problem again on Developer Community to raise the priority .


0 Votes 0 ·

Happens to me, updated VS and Profiler, does not work

0 Votes 0 ·

0 Answers