question

ITTechPR-8517 avatar image
0 Votes"
ITTechPR-8517 asked ·

Replication Agent Error after manual update

I had an agent that wasn't updating from the Azure portal so I decided to manually update it.
After uninstalling the old agent and installing the new one I'm getting some replication errors,
althought the connection to the agent is detected (Information of the current agent wa

I've already tried restarting and deleting the whole replicated server on Azure and reinstalling the agent still the synchronization is stuck at 0% on Azure portal. Communication between source and process machine seems to be the issue. I've already checked port 443 & 9443 are both open and receiving.

After digging through some logs I found the following errors:


(06-04-2021 18:56:05): ERROR 10312 7904 2 main Sentinel cought exception: i:\src\release\inmage-azure-siterecovery\host\azurercmlib\rcmconfigurator.cpp(120)[RcmClientLib::RcmConfigurator::Init] Insufficient information to initialize RCM client hostid XXXXXX-XXXXX-XXXX-XXXX-XXXXXXXX installpath C:\Program Files (x86)\Microsoft Azure Site Recovery\agentrcmSettingsPath

~> (06-04-2021 18:56:11): ERROR 7868 10392 1 FAILED: Unable to instantiate configurator. Quitting sentinel


Event Viewer every second showed error with s2RCM.exe

Everything on the process server seems right, although when checking the cxpsclient logs I found that the log had a /getfile command send from the replicated server and instantly /deletefile ,this behavior was weird since the other VMs that are replicating didn't showed this behavior (Sorry I forgot to grab the logs from this one so I'm saying what I remember from the top of my head)

Again this used to be working until trying to update the agent from the portal, then tried installing manually but couldn't so ended up reinstalling the agent from the repository of the Configuration server.

Any advice or suggestion is welcomed



azure-site-recovery
· 1
10 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@ITTechPR-8517 Sorry for the delayed response!

Please follow the steps from this guide - https://docs.microsoft.com/en-us/azure/site-recovery/vmware-azure-troubleshoot-configuration-server#upgrade-fails-when-the-services-fail-to-stop

Hope it helps!


If the response helped, do "Accept Answer" and up-vote it

0 Votes 0 ·

0 Answers