question

TonyB-9562 avatar image
0 Votes"
TonyB-9562 asked TonyB-9562 edited

Why is SharePoint 2016 User Profile service not importing updated user info from AD?

I have a SharePoint 2016 farm setup and I'm using AD Importer to import users. New users are successfully imported into SharePoint but if I update Department, Title, Job Title in AD the changes don't appear in SharePoint.

How can I fix this?

office-sharepoint-server-administration
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

TonyB-9562 avatar image
1 Vote"
TonyB-9562 answered TonyB-9562 edited

I opened a support case with Microsoft and the tech stated SharePoint Active Directory Import will only import users from AD if all Users and Containers are selected under the Users Container. I selected all Users and Containers and importing worked. However, the Employee Directory displays all this information which is not needed. To get around this I changed the query text under People Search Core results to {searchboxquery} @emailaddress.com. It appears only users with a company email address are searchable, which is what we want.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ElsieLu-MSFT avatar image
0 Votes"
ElsieLu-MSFT answered ElsieLu-MSFT edited

Hi @TonyB-9562 ,

To narrow down your issue:
1.Are you unable to update user information in Manage User Profiles>Find profiles?
107479-image.png

2.Are you running Full Sync? If it is incremental sync, you could try to run Full Synchronization to see if it works.
107516-21.jpg

3.Are the attributes of all users not updated or are they just new users?

===============Update1=======================

As this post mentioned, you could try to run:

 stsadm -o sync -listolddatabases 0

If there are any => few hours, run:

 stsadm -o sync -deleteolddatabases 0

Then, run the Full Sync timer job again. Re-check your site collection (or re-run stsadm -o sync -listolddatabases 0 to see that their time is current).


If the answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


image.png (16.7 KiB)
21.jpg (26.7 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

TonyB-9562 avatar image
0 Votes"
TonyB-9562 answered WedershovenUrs-4438 commented
  1. I can update users in Manage User Profiles-Find profiles. 2. Full sync runs every night and incrementals run every 5 minutes. 3. This affects all users.

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @TonyB-9562 , I have updated my answer, please kindly check the update1 section. If the issue persists, don't hesitate to let us know.

0 Votes 0 ·

Hi ElsieLu,

I ran stsadm -o sync -listolddatabases 0 at 8:50 am EST today and received the following:

109431-remotedesktopmanager64-uyed9nzg27.png




Why would it show a synchronized time in the future?

0 Votes 0 ·

I guess the times are UTC. When I run the command in CEST timezone, they are all 2h in the past (which is fine!).
Nevertheless: I have the same problem and I do not have any further clues, either.

0 Votes 0 ·
TonyB-9562 avatar image
0 Votes"
TonyB-9562 answered

Any other thoughts on this?

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

TonyB-9562 avatar image
0 Votes"
TonyB-9562 answered

Checking "Users" OU selects all users and OU's underneath "Users" and importing works.

However, this imports users/accounts that don't need to be imported.

Unticking a user in "Users" or unticking an OU underneath "Users" unticks Users underneath "Users" which appears to break importing.

137006-remotedesktopmanager64-uxcnj8opit.png


Is this a bug or normal behavior?



5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.