question

StaroadJeffrey-8329 avatar image
4 Votes"
StaroadJeffrey-8329 asked joshyates1980 commented

Azure CDN endpoint stuck on "Pending domain validation approval"

Hi
I have two CDN custom domain that has been unable to validate for the past 1-2 weeks. My other custom domains successfully validated within an hour or so, but this one never progresses. I tried deleting the custom domain after a week and re-adding it, but that hasn't helped. I added the cdnverify CNAME records in advance like I did for my other custom domains, and this domain doesn't have email set up on it so there was no validation request. It's not clear to me why the process has stalled. Is there any way to investigate why it's taking so long?

azure-cdn
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

We are also running into the same issue, both on a CDN resource and Front Door resource.
We have other environments with both of these resources working, however the resources created in the past 1-2 weeks have not been automatically validating.
Hopefully someone can give some guidance on why this may be happening.

0 Votes 0 ·
TravisCragg-MSFT avatar image
0 Votes"
TravisCragg-MSFT answered joshyates1980 commented

There are known issues with domain validation, particularly with Azure CDN. If your domain is not validating in a reasonable amount of time (more than 2 days), your best bet is to open a support request to investigate further on why it is not validating. If you do not have a support plan, please Email me at azcommunity@microsoft.com with your subscription ID and a link to this post, along with replying to this comment to let me know you have emailed. I will enable your subscription for a one-time free support request to troubleshoot further.

· 18
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I am having this same issue, and have sent an email to the address listed. Looking forward to getting it resolved!

0 Votes 0 ·

Experiencing the same issue - email sent.

0 Votes 0 ·

Hi,

I have the same issue. I sent an email to the address above. Thanks.

0 Votes 0 ·

I have the same issue. After waiting 2 days, no email was received, and no the status was still saying pending validation. (Yes - all the email addresses such as webmaster@mydomain.com, postmaster@mydomain.com, administrator@mydomain.com etc get delivered to my mailbox, and noting was in quarantine or in junk folders).

I have deleted the custom domain & now waiting the 8 hrs for it to clean up prior requests, then I will try again.

I am attempting to add the root domain as a custom domain (i.e. mydomain.com) and have thus used the cdnverify process, as it is not possible to create a CNAME record for the root of a domain. A CNAME record exists for cdnverify.mydomain.com and points to cdnverify.mydomainwebsite.azureedge.net (mydomainwebsite.azureedge.net being the CDN endpoint hostname)
There is no ANAME record in DNS as yet (I will create this once the custom domain process has completed).

0 Votes 0 ·

I have re-created the custom domain name & waited over 24 hrs - the same problem occurs.
I have sent an email to azcommunity@microsoft.com

It seems this is a common problem - it would be good if someone from MS would post details in one of the forums on how to avoid it.

0 Votes 0 ·
Show more comments
ryanchill avatar image
0 Votes"
ryanchill answered

For those that are experiencing this [similar] issue, CDN managed certificates are not provided for APEX/root level domains. You will have to use your own certificate brought from a CAA to enable HTTPS. See the follow docs for reference:

Regards,
Ryan



5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.