question

SmithMark-8744 avatar image
0 Votes"
SmithMark-8744 asked JiaYou-MSFT commented

RDP sessions slowing down after upgradig from Win10 1809 to Win10 1909

My organization recently upgraded all our Windows 10 PC's from running Enterprise 1809 to Enterprise 1909 using the MS In-place upgrade process.

Among the 150 or so units were 35 PC's hosting RDP remote workers. Of the 35 users, all but one are running conventional enterprise-class host desktop PCS...mostly HP but some Dell Intel i5's (6th to 9th generation), 8GB RAM and the on-board Intel video stage. One unit however is an HP Z-station with the following specs:

HP Z4 G4 Workstation - 1 x Intel Xeon Hexa-core (6 Core) W-2133 3.60 GHz - 16 GB DDR4 SDRAM RAM - 2 TB HDD - 512 GB SSD - Mini-tower - Black - Windows 10 Pro 64-bitNVIDIA Quadro P4000 8 GB Graphics

For just this one workstation, after the In-place upgrade the end-user, also using an HP Z-Book workstation laptop, found that after 15-30 minutes that he was experiencing long lag-times. After 30-60 minutes the connection became essentially unusable and he would have to perform restarts. After some experimentation we have found that by setting the screen-saver on the host workstation to higher values that it increases how long the user can effectively work, from 15-30 minutes to around 2-3 hours. The power profile for the unit is High-Performance, and as the PC is at this time only being used via RDP, and therefore the local monitor should not be being engaged anyway, what could be causing this behavior?

Thank you for any input.

remote-desktop-servicesremote-desktop-clientwindows-10-hardware-performance
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

HI
Is there any progress on your question?

0 Votes 0 ·

HI
Is there other thing to help you?

0 Votes 0 ·

HI

Is there other thing to help you?

0 Votes 0 ·
yagmoth555 avatar image
0 Votes"
yagmoth555 answered

Hi

There is a know issue that can make the remote session really slow. It’s related to the mouse pooling rate from the pc where the connection come from.

I dont know if it’s your case, but it’s worth checking.

To explain the bug; It’s on the user computer, if he has a mouse like a gaming’s one, any rate over 500 make the remote session act poorly. Return the pooling rate to the default of 125 in the mouse driver to fix the issue if it’s your issue there.

Thanks

Philippe

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JiaYou-MSFT avatar image
0 Votes"
JiaYou-MSFT answered

HI

1.Do your issue happen when you remote access from win10(1909) PC to win10(pro) HP workstaion?

2.Could you please enter below command on issue win10(1909) then look the update history?
get-hotfix

Resolved issues in Windows 10, version 1909 and Windows Server, version 1909
https://docs.microsoft.com/en-us/windows/release-health/resolved-issues-windows-10-1909

3.Please enter below command to open local group policy and enable below policy on HP Z4 G4 Workstation.
gpedit.msc
Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment
Use the hardware default graphics adapter for all Remote Desktop Services sessions enable

============================================
If the Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.