question

Williams-9598 avatar image
0 Votes"
Williams-9598 asked DSPatrick commented

How do you enable remote login on a Hyper-V virtual machine?

I have a Win Svr 2012 virtual machine (Hyper-V).
I switch over to Enhanced mode (which I must) and I can no longer login.
If I flip it back to basic mode, I can log back in no problem.

I receive this error:

To sign in remotely, you need the right to sign in through Remote Desktop Services. By default, members of the Remote Desktop Users group have this right. If the group you're in doesn't have this right, or if the right has been removed from the Remote Desktop Users group, you need to be granted this right manually.

I've confirmed that:
- Both the Remote Desktop Services and the Remote Procedure Call (RPC) service are running
- The account in use is a part of the local Administrators group as well as the Remote Desktop Users group.
- That the virtual host allows the use of enhanced mode.

Appreciate any insight.



remote-desktop-serviceswindows-server-hyper-v
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

DSPatrick avatar image
1 Vote"
DSPatrick answered DSPatrick commented

Might try to add users;

Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment\Allow logon locally

Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment\Allow log on through Remote Desktop Services

--please don't forget to upvote and Accept as answer if the reply is helpful--



· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

This did not resolve my issue (at least directly) as the groups were already listed; however, I did see the policy Deny remote logon policy there.
That policy was denying local accounts. It worked after I removed that.
Thanks for the assist.

0 Votes 0 ·

Glad to help, you're welcome.


0 Votes 0 ·