question

KingJava avatar image
0 Votes"
KingJava asked KingJava edited

Stored Procedure not Executing from normal operation in Azure Data Factory but works from "Rerun from activity"

I am just not sure how to resolve this issue.

I have a pipeline where it executes a stored procedure (after one step called "Copy data").

When I run the Pipeline, the second step where stored procedure has to do the job does not do the job as expected.

There is no issue with the stored procedure because when I run the stored procedure directly from SQL Server management studio, it works.

This is normal operation, but there is no output (inserting data into table) from Stored Procedure even though it says 'Succeeded':
121990-image.png


Bottom option is available in "Activity runs" mode (after job is done):
When I press "Rerun from activity" (on the Stored procedure step), stored procedure does work.

122049-image.png




I am not sure where to test or fix on this issue.

azure-data-factorysql-server-transact-sql
image.png (26.1 KiB)
image.png (22.1 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

0 Answers