question

NhatHoang-7529 avatar image
1 Vote"
NhatHoang-7529 asked BGOAdmin-7031 answered

EDGE: File was blocked because this type of file can harm your device

Hi everyone,

I believe after the window update on May or June, the Edge started to warn when downloading some types of file like xml, msg on all domains. 122440-downloadwarning.png



I tried to use the policy on Edge: https://docs.microsoft.com/en-us/deployedge/microsoft-edge-policies#disable-download-file-type-extension-based-warnings-for-specified-file-types-on-domains

That policy will not work with the download link like this: blob:https//. I tried domain.com, https://domain.com, https://www.domain.com, blob:https://domain.com, etc
Only ["*"] will work but it will bypass for all domains. I just want to bypass for only 1 domain.

Can you help me how to make it work with the download URL with that schema (blob:https://) ?

Thank you,

ms-edge
downloadwarning.png (10.0 KiB)
· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @NhatHoang-7529 , You mentioned that ["*"] works in your case, so I'm not sure if your configuration is correct. Is it possible that the domains parameter is incorrectly configured? Did you update the policy after configuration?

0 Votes 0 ·

Hi @XuDongPeng-MSFT ,

Thanks for your response.

These are my settings that did not work:

[{ "file_extension": "xml", "domains": ["domain.com"] }
{ "file_extension": "xml", "domains": ["www.domain.com"] }
{ "file_extension": "xml", "domains": ["https://domain.com"] }
{ "file_extension": "xml", "domains": ["https://www.domain.com"] }
{ "file_extension": "xml", "domains": ["https://*.domain.com"] }
{ "file_extension": "xml", "domains": ["*.domain.com"] }

Only this one worked:

{ "file_extension": "xml", "domains": ["*"] }

II tested those settings in the lab domain and it worked normally with the download URL starts with https://domain.com. but my prod download URL is blob:https://domain.com/..... and it did not work.

Looks like that policy does not work in the URL with the mixed schema like this: blob:https://

0 Votes 0 ·

Hi @NhatHoang-7529 , Although https and blob are both standard schemes, but it seems that we can only use one schema in the pattern. I found that someone has encountered the same problem as you: Filter format for URL list-based policies in Edge.

1 Vote 1 ·
Show more comments
Luke-6623 avatar image
1 Vote"
Luke-6623 answered

@NhatHoang-7529 - Just FYI this is now working in Edge v93. MS confirmed in a support ticket that it was a bug. The following works in my use-case...

{"domains": ["custom.domain.com"], "file_extension": "msg"}

Note, you do not need the URL schemes in the domains part of the setting

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

NhatHoang-7529 avatar image
0 Votes"
NhatHoang-7529 answered Luke-6623 commented

Hi @Luke-6623

Thanks for your information. It works good. do you know if they fixed it or it's just a workaround?

Thank you again.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@NhatHoang-7529 Yes believe they fixed properly

0 Votes 0 ·
BGOAdmin-7031 avatar image
0 Votes"
BGOAdmin-7031 answered

Thanks @NhatHoang-7529, this was very helpful!
I needed this to work in order to download XML files from https://config.office.com.
Before using the group policy with {"domains": ["config.office.com"], "file_extension": "xml"} the download was completely blocked with no dialogue allowing override.
Now I am advised that it's risky but I can proceed to download. Saved my deploying Office 365... :-)

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.