question

NickWilson-1467 avatar image
3 Votes"
NickWilson-1467 asked felipementel answered

Unable to get Function Host running, with the following error: Functions runtime errorMicrosoft.Azure.WebJobs.Script: Did not find functions with language [dotnet].

Hello,

I am attempting to follow this guide: https://docs.microsoft.com/en-us/azure/azure-functions/functions-create-function-linux-custom-image?tabs=bash%2Cportal&pivots=programming-language-python , up until the section of 'Verify your functions on Azure' as I am unable to do so. The only deviation I believe I have made is using a B1 plan as opposed to EP1.

So far, I have pushed my image to docker, and linked it to an azure function app. The docker image runs fine locally (Windows 10). However, when I visit the azure function app I see the following error appears in the app overview, as a notification:

Functions runtime errorMicrosoft.Azure.WebJobs.Script: Did not find functions with language [dotnet].

Visiting the HTTP trigger / azure site shows that the function host is not running (I assume because of this error). As I am following a guide I am unsure of what to do next, and was advised to open a ticket by the person I spoke with in the support chat.

Cheers,
Nick

azure-functions
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@NickWilson-1467, Just following up here...did the below mentioned answer resolve your issue?



0 Votes 0 ·
ChaitanyaNaykodiMSFT-9638 avatar image
1 Vote"
ChaitanyaNaykodiMSFT-9638 answered

@NickWilson-1467, Thank you for reaching out, I am sorry for the delay in my response.
I was able to replicate error on my end.
13498-1.png


Below is the solution which worked for me.

  1. On Azure Portal go to your <YourFunctionApp> scroll down on the left panel to go to “Configuration” under "Application settings" and click on “Advanced edit”.
    13440-configuration-settings.png


  2. Change the “FUNCTIONS_WORKER_RUNTIME” setting to “python” as shown below.
    13457-functionworkerruntime.png

  3. Click “Ok” then validate and “Save”. This will restart your function app (if not then manually restart it from the overview tab).
    13426-saving-the-changes.png

  4. It will take a couple of minutes for the function to restart. On the “Overview” tab, click “Refresh” a couple of times and the error pop-up will vanish.

This also can be done using the “Azure CLI” by running the command mentioned below.

az functionapp config appsettings set --name <function_app> --resource-group <my_resource_group> --settings FUNCTIONS_WORKER_RUNTIME=python


Even though we are setting the “worker_runtime” to “python”, it is not getting reflected when deployed to the portal. This can be achieved by adding “--runtime python” to the below command in the tutorial.

az functionapp create --name <app_name> --storage-account <storage_name> --resource-group AzureFunctionsContainers-rg --plan myPremiumPlan --deployment-container-image-name <docker_id>/azurefunctionsimage:v1.0.0 --runtime python

I will contact the product team and get this rectified. I hope this resolves the issue you are facing, let me know if it does not, I will be happy to help.












5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

KomalGrover-5498 avatar image
0 Votes"
KomalGrover-5498 answered KomalGrover-5498 commented

I am getting the same error but with 'python'
Microsoft.Azure.WebJobs.Script: Did not find functions with language [python].
Value cannot be null.
Parameter name: provider

I have set the function_runtime_worked_ as python, still it is giving the same error. Can anyone please help ?

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Did you get this solved?, I have the same issue

0 Votes 0 ·

No :( Still facing the same issue

0 Votes 0 ·

got it resolved now. I installed Azure functions tool again using npm i -g azure-functions-core-tools@2 --unsafe-perm true
After that instead of running using launch.json, I used node.js to attach to python function and executed the function.

0 Votes 0 ·
RobBowman147 avatar image
4 Votes"
RobBowman147 answered

If using dotnet 5.0 make sure FUNCTIONS_WORKER_RUNTIME configuration value is "dotnet-isolated"

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

felipementel avatar image
0 Votes"
felipementel answered

based on https://docs.microsoft.com/en-us/azure/azure-functions/functions-run-local?tabs=v3%2Cwindows%2Ccsharp%2Cportal%2Cbash%2Ckeda



try to install the package azure-functions-core-tools v3, like command bellow

npm install -g azure-functions-core-tools@3 --unsafe-perm true

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.