question

TangiralaDineshReddy-1882 avatar image
0 Votes"
TangiralaDineshReddy-1882 asked KranthiPakala-MSFT commented

unable to create datalake analytics account and throwing providelocation is not found in azure portal

I try to create datalake anyaltics account. But error is coming.

please find the below screenshot.

124285-image.png


I tried using azure datalake storage gen1 option and throwing below error.

124275-image.png




I tried creating with out selecting option datalake storage gen1 option. it is not showing any thing error but not creating.

azure-data-lake-storageazure-data-lake-analytics
image.png (42.5 KiB)
image.png (32.3 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Try some other location like Central US.. and also try creating ADLS Gen1 separately and use it in the drop down.

0 Votes 0 ·

1 Answer

KranthiPakala-MSFT avatar image
0 Votes"
KranthiPakala-MSFT answered KranthiPakala-MSFT commented

Hi @TangiralaDineshReddy-1882,

Thanks for using Microsoft Q&A forum and posting your query.

Could you please confirm if you are trying to create a new ADLS Gen1 account? If yes, is this the very first ADLS Gen1 account you are trying to create? If that is the case then this is an expected behavior when you try to create a new Azure Data Lake Storage Gen1 storage account for the first time on or after July 5, 2021.

According to Azure Data Lake Storage Gen1: Account creation will be blocked for new customers starting July 5, 2021 | Azure updates | Microsoft Azure. Starting July 5, 2021, customers who don’t have an existing account on Azure Data Lake Storage Gen1 will not be able to create new Azure Data Lake Storage Gen1 accounts.

124569-image.png

As per the below announcement ADLS Gen1 is in the path of deprecation. I assume the same with ADLA as ADLA supports only ADLS Gen1. Hence, we would recommend all the customers to use Azure Synapse Analytics with ADLS Gen2 accounts.

Recent announcement: Azure Data Lake Storage Gen1 - Retirement Announcement

Can I use ADLA with ADLS Gen2 accounts?

ADLA (Azure Data Lake Analytics) is not supported on ADLS Gen2 today, given we are not investing in ADLA, we do recommend customers migrate ADLA to an alternate framework such as Azure HDInsight, Azure Synapse Analytics or Azure Databricks.

124677-image.png

Reference: Azure Data Lake Storage Gen1 - Retirement Announcement

In case, if you still need the support to create ADLA and ADLS Gen1 accounts, please do create a support ticket or please email to ADLSGen1toGen2MigrationQA@service.microsoft.com so that relevant product team provide guidance accordingly.

Hope this info helps. Do let us know if you any further queries.



  • Please accept an answer and up-vote if it helps. Original posters help the community find answers faster by identifying the correct answer. Here is how.

  • Want a reminder to come back and check responses? Here is how to subscribe to a notification.





image.png (270.5 KiB)
image.png (101.1 KiB)
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @TangiralaDineshReddy-1882,

We still have not heard back from you. Just wanted to check if the above information was helpful? If it answers your query, please do click “Accept Answer” and/or Up-Vote, as it might be beneficial to other community members reading this thread. And, if you have any further query do let us know.

0 Votes 0 ·

Does that mean the service Azure Data lake analytics is replaced by Azure Synapse? Can we not use azure data lake analytics with azure data lake storage gen 2?

0 Votes 0 ·
KranthiPakala-MSFT avatar image KranthiPakala-MSFT RamanathanDakshinaMurthy-0993 ·

Hi @ramanathandakshinamurthy-0993,

Yes, as per the latest announcement from Product Team, called out in my previous response, ADLA will not support ADLS Gen2. Hence recommended to use other Azure services like Azure HDInsights, Azure Synapse Analytics, Azure Databricks.

Hope this helps.

0 Votes 0 ·