question

yash121 avatar image
0 Votes"
yash121 asked yash121 commented

Get the Azure Analysis services Activity logs using Kusto query

Hello,

I'm trying to run the following queries to get the information of following administrative activities performed on the Azure Analysis Resource . But i'm not able to get the results. results are empty.

AzureActivity | where OperationNameValue == \"Microsoft.AnalysisServices/servers/suspend/action\" and ActivityStatusValue == \"Succeeded\"
AzureActivity | where OperationNameValue == \"Microsoft.AnalysisServices/servers/resume/action\" and ActivityStatusValue == \"Succeeded\"
AzureActivity | where OperationNameValue == \"Microsoft.AnalysisServices/servers/write\" and ActivityStatusValue == \"Succeeded\"


I would be glad if anyone from the community team can help me to solve the above queries?


Regards,
yash

azure-analysis-services
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

PRADEEPCHEEKATLA-MSFT avatar image
0 Votes"
PRADEEPCHEEKATLA-MSFT answered yash121 commented

Hello @yash121,

Welcome to the Microsoft Q&A platform.

You may try the below Kusto Query to get the Azure Analysis Services Activity logs.

To get all the Azure Analysis services by passing the ResourceProviderValue:

 AzureActivity
 | where ResourceProviderValue == "MICROSOFT.ANALYSISSERVICES" 

124618-image.png

To get multiple operations in the single kusto query using OperationNameValue:

 AzureActivity 
 | where OperationNameValue == "MICROSOFT.ANALYSISSERVICES/SERVERS/RESUME/ACTION" or OperationNameValue == "MICROSOFT.ANALYSISSERVICES/SERVERS/SUSPEND/ACTION" and ActivityStatusValue == "Success"

124619-image.png

Hope this helps. Do let us know if you any further queries.


Please "Accept the answer" if the information helped you. This will help us and others in the community as well.


image.png (138.4 KiB)
image.png (126.4 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thanks Pradeep. You are a Life Saver!

I

1 Vote 1 ·