question

healee-5771 avatar image
2 Votes"
healee-5771 asked KevinNeves-2588 published

How to get rid of English (United States) US keyboard?

I have keyboard set to English (Australia) US keyboard. When English (United States) US keyboard is selected there is no “remove” option available as on Windows 7 system.

Moreover the language bar is always available at the bottom corner though I have set it to be hidden. How can I prevent it to show up there?

windows-10-setup
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,

Just checking in to see if the information provided was helpful.

If the reply helped you, please remember to mark it as an answer.
If no, please reply and tell us the current situation in order to provide further help.

0 Votes 0 ·
JennyFeng-MSFT avatar image
0 Votes"
JennyFeng-MSFT answered

Hi,

To fix this issue, delete the Preload registry folder and sign out or restart the computer:
HKEY_USERS.DEFAULT\Keyboard Layout\Preload

Note: Make sure that you back up the registry before you modify it.

While the fix itself works through restarts, at time of writing there's things that bring back that pesky folder, whenever the problem comes back, that registry folder needs to be deleted again.

In addition, here are some posts with the similar issue with yours, just for your reference, you can try the method mentioned in them:
https://superuser.com/questions/1092246/how-to-prevent-windows-10-from-automatically-adding-keyboard-layouts-i-e-us-ke#:~:text=Go%20to%20to%20Region%20and,keyboard%20and%20you're%20done.
Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.

Hope above information can help you.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

KapilArya avatar image
1 Vote"
KapilArya answered

Hello,

Try to set English (Australia) as preferred language and see if you can remove English (United States) keyboard layout then:

Open administrative Windows PowerShell

Run this command to get a list of installed languages on your PC

Get-WinUserLanguageList

Note down the LanguageTag of your preferred language

If say, your preferred language is US English, run this command and hit Enter:

$1 = New-WinUserLanguageList en-US

Then run this command to set the order of installed input languages

Set-WinUserLanguageList $1

Close Windows PowerShell.

Hope this helps!

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Brisbane-3628 avatar image
5 Votes"
Brisbane-3628 answered KevinNeves-2588 published

This may sound weird but worked for me:

Settings -> Language (no en-US is shown )

Add a language, choose English (United States). Then remove English (United States) after it's shown.

No more English (United States)

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Did not expect this to work, but it did. Thanks for the simple solution

0 Votes 0 ·

omg, its work. Thanks!

0 Votes 0 ·

Thank you for the solve :)

0 Votes 0 ·

Works 100%

0 Votes 0 ·