question

Guilhaume-2096 avatar image
0 Votes"
Guilhaume-2096 asked ErnestoSanchezFernandez-1483 commented

Windows 2016 -RDS user get temp profile - Error Code 0x4005.135 then 0x20.135

Hello,



I have a strange and random problem with only one different user per day on RDS over 100 active users.

We use Windows Server 2016.



To explain :

  • User connect on our RDS farm through a broker

  • For the user that have the problem, we see that his profile is loading but at the end it finished with a temp profile

  • It happens only once a day, only for one user and with different server from the farm.

  • udp uses vhdx

  • problem since august friday 27th



Searching on event viewer, I've found that at the first openning session from the user who got the problem that there is an error with Microsoft-Windows-TerminalServices-RemoteConnectionManager/Admin - Error code 0x4005.135

Then, on next try, errors are Microsoft-Windows-TerminalServices-RemoteConnectionManager/Admin - Error code 0x20.135



I've seen over Microsoft Community that I had to delete "***.bak" registry on ProfileList on Regedit, even the ProfilGuid registry but it doesn't work.

I've tried to move or rename the udp disk but I can't because it says that it's actually locked by System.

I've search on all RDS server and the udp disk is not mounted.



It seems that rebooting the server broker temporary correct the problem.... but only temporary.



Thanks for your help.

windows-serverremote-desktop-serviceswindows-server-2016
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LimitlessTechnology-2700 avatar image
0 Votes"
LimitlessTechnology-2700 answered

Hello @Guilhaume-2096

Thank you for your question

Try repairing your system files: Select the Start button and type command prompt in the search box on the taskbar. Choose Command Prompt from the list of results. In the window that appears, type DISM.exe /Online /Cleanup-image /Restorehealth and press the Enter key.

For more information please go through this link:
https://support.microsoft.com/en-us/windows/get-help-with-windows-10-upgrade-and-installation-errors-ea144c24-513d-a60e-40df-31ff78b3158a

If the reply was helpful, please don't forget to upvote or accept as answer.

Thanks,

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LimitlessTechnology-2700 avatar image
0 Votes"
LimitlessTechnology-2700 answered

Hello again,

In addition, if the profiles still not deleted by renaming upd or registry.

Please delete profile having issues from all RDS servers from System Properties -> Advanced -> User Profiles -> Settings -> Select the username and click delete.

If the reply was helpful, please don’t forget to upvote or accept as answer.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Guilhaume-2096 avatar image
0 Votes"
Guilhaume-2096 answered

Hello,

Thanks for your time.

I've tried each of those solutions but I still have this probleme :
- DISM and sfc have found errors et correct it
- Windows is up to date
- I've tried with antivirus and firewall unactivated
- There still is lot of free disk space
- deleting *.bak registry doesn't correct it

I've tried going to System Properties -> Advanced -> User Profiles -> Settings ... but username disappear when user disconnect.

I'm completely lost with that...





5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LucasMacBeth-0013 avatar image
0 Votes"
LucasMacBeth-0013 answered

Hi @Guilhaume-2096,

I have this same issue with 2 of my clients but they are running Server 2012 R2. With your issue when it happens is the User Profile Disk still mounted on a Remote Desktop Session Host but with no Volume Label?

I login to the Session Host and disconnect the User Profile Disk manually via Disk Management which temporarily resolves the issue.

Still haven't worked out what is causing the problem

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Guilhaume-2096 avatar image
0 Votes"
Guilhaume-2096 answered

Hi,

I've search for that solution too but i've only found "User Disk" from users already connected that do not have the problem.
I have no blank labaled Volume (exept for EFI et repare parts)

Thanks

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LucasMacBeth-0013 avatar image
0 Votes"
LucasMacBeth-0013 answered

Hi @Guilhaume-2096,

Sounds like mine might be a separate issue to yours then. When the user in question is having issues the User Profile Disk is mounted on a RDSH with no volume label.

129831-image.png



image.png (65.6 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Guilhaume-2096 avatar image
0 Votes"
Guilhaume-2096 answered

OH !

I didn't search on the bottom tile but only the top one.

Thank you verry much.
At least I can "unlock" their profils now without having to reboot the broker.

TY.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Guilhaume-2096 avatar image
0 Votes"
Guilhaume-2096 answered Guilhaume-2096 edited

Hello @LucasMacBeth-0013 @LimitlessTechnology-2700

Still couldn't find a solution.
It seems more that it can't finish to mount user disk at loggon but not on loggoff.
When I unmount disk from user that have the problem et unlock their session, a random user that loggon after that, several minutes after, get the same problem.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SML-1156 avatar image
0 Votes"
SML-1156 answered

Hi all,
we are also seeing the issue on a farm. it might be related to the update KB5005030 or KB5005102.
After these the problem startet appearing. - Also we were seeing that one specific server was not getting sessions. Removing and readding it solved that in the that case, but the disk that are stuck to the server still persists.

Noticably, if you try to set a drive letter for that vdisk, there is an error message that the snap in is not up-to-date....

I will try to do some digging and maybe come back.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ErnestoSanchez-5851 avatar image
0 Votes"
ErnestoSanchez-5851 answered

Any news about this?
We have the same problem with W2012 R2 but in our case is not enough to remove the unlabeled disk from disk management, we have to reboot the server (only one server with RDS and the rest of roles on it and 20 users)

Thanks

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.