question

Solveit123-0287 avatar image
0 Votes"
Solveit123-0287 asked ·

Connector Id And connector IP are blank in Message trace

Hello Team,
When i ran the Get-messagetracelog we do not get the connector ID and client IP it shows only blank.

What I have observed I do see that connector ID and client IP populated only Event type(Send & receive) and source(SMTP). But I do not see any connector details in Event type(HARDReceive, HARD discard,etc) . any input and thought. is this expected behaviour in exchange 2016 ?

office-exchange-server-administrationoffice-exchange-hybrid-itpro
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AndyDavid avatar image
0 Votes"
AndyDavid answered ·

Correct. Those fields are meaningless in the context of Shadow Redundancy.

10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

EricYin-MSFT avatar image
0 Votes"
EricYin-MSFT answered ·

You can search the value's meaning in Message tracking.


14473-3.png


14501-5.png



3.png (32.6 KiB)
5.png (25.9 KiB)
· 1
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi, I'm here to confirm with you if your issue has been resolved. If the problem is successfully solved, you can share your solution and mark them or the helpful reply as answer, this will make answer searching in the forum easier and be beneficial to other community members as well.

0 Votes 0 ·
Solveit123-0287 avatar image
0 Votes"
Solveit123-0287 answered ·

Hello All,

Sorry looks like issue still there I am unable to see right receive connector id in message trace its shows always Default receive connector only.

I have created custom connector that suppose to show on message trace but it shows only Default receive connector. any inputs and thoughts. @EricYin-MSFT

10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AndyDavid avatar image
0 Votes"
AndyDavid answered ·

Ok, these are two different questions. The first I already answered.

For the second, you wont find that in message tracking, you need to look at the protocol logs ( enable them if necessary)
That will show you the connector used

https://docs.microsoft.com/en-us/exchange/mail-flow/connectors/configure-protocol-logging?view=exchserver-2019

Enable for the receive connectors you want

10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

EricYin-MSFT avatar image
0 Votes"
EricYin-MSFT answered ·

@Solveit123-0287
Use this command and you should see the connector name in EventID Send and EventID Receive:

 Get-TransportService | get-messagetrackinglog 


· 2
10 |1000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

That will only show the default receive connector, not the actual receive connector used.
The ConnectorID only shows the correct connector for SEND events, not RECEIVE in message tracking.

to see the actual receive connector used in receive events, SMTP protocol logging must be enabled and those logs show the connector used.

0 Votes 0 ·

I am writing here to confirm with you how the thing going now?
If you need further help, please provide more detailed information, so that we can give more appropriate suggestions.

0 Votes 0 ·