question

splover avatar image
0 Votes"
splover asked sadomovalex edited

Sharepoint server 2013: unexpected error when opening library pages

When opening any library page, in random moments unexpected errors occur. It is not correlating with usage of the server or anything I can think of.
Here is ULS log file associated with correlation id from one of errors:

Timestamp : 9/6/2021 8:42:40 AM
Continuation : False
Process : w3wp.exe (0x14EC)
ThreadID : 3708
Area : SharePoint Foundation
Category : Logging Correlation Data
EventID : xmnv
Level : Medium
Message : Name=Request (GET:https://januszex.com:443/orders/SitePages/All.aspx)
Correlation : 51c0ec9f-6402-400f-ed14-ee6800073b9c
Context : {}

Timestamp : 9/6/2021 8:42:40 AM
Continuation : False
Process : w3wp.exe (0x14EC)
ThreadID : 3708
Area : SharePoint Foundation
Category : Authentication Authorization
EventID : agb9s
Level : Medium
Message : Non-OAuth request. IsAuthenticated=True, UserIdentityName=0#, ClaimsCount=357
Correlation : 51c0ec9f-6402-400f-ed14-ee6800073b9c
Context : {}

Timestamp : 9/6/2021 8:42:40 AM
Continuation : False
Process : w3wp.exe (0x14EC)
ThreadID : 3708
Area : SharePoint Foundation
Category : Files
EventID : aiv4w
Level : Medium
Message : Spent 0 ms to bind 3356 byte file stream
Correlation : 51c0ec9f-6402-400f-ed14-ee6800073b9c
Context : {}

Timestamp : 9/6/2021 8:42:40 AM
Continuation : False
Process : w3wp.exe (0x14EC)
ThreadID : 3708
Area : SharePoint Foundation
Category : Logging Correlation Data
EventID : xmnv
Level : Medium
Message : Site=/
Correlation : 51c0ec9f-6402-400f-ed14-ee6800073b9c
Context : {}

Timestamp : 9/6/2021 8:42:40 AM
Continuation : False
Process : w3wp.exe (0x14EC)
ThreadID : 3708
Area : SharePoint Foundation
Category : Monitoring
EventID : b4ly
Level : High
Message : Leaving Monitored Scope (PostResolveRequestCacheHandler). Execution Time=24,9067269722828
Correlation : 51c0ec9f-6402-400f-ed14-ee6800073b9c
Context : {}

Timestamp : 9/6/2021 8:42:40 AM
Continuation : False
Process : w3wp.exe (0x14EC)
ThreadID : 3708
Area : SharePoint Portal Server
Category : Search Boxes
EventID : ahvv6
Level : Unexpected
Message : Fetching app info failed: Microsoft.Office.Server.Search.Query.SearchServiceNotFoundException: The search request was unable to connect to the Search Service. at
Microsoft.Office.Server.Search.Administration.SearchServiceApplicationProxy.GetProxy(SPServiceContext ServiceContext) at
Microsoft.Office.Server.Search.WebControls.SearchCommon.GetSearchCenterUrl()
Correlation : 51c0ec9f-6402-400f-ed14-ee6800073b9c
Context : {}

Timestamp : 9/6/2021 8:42:40 AM
Continuation : False
Process : w3wp.exe (0x14EC)
ThreadID : 3708
Area : SharePoint Portal Server
Category : Search Boxes
EventID : ahvv6
Level : Unexpected
Message : Fetching app info failed: Microsoft.Office.Server.Search.Query.SearchServiceNotFoundException: The search request was unable to connect to the Search Service. at Microsoft.Office.Server.Search.Administration.SearchServiceApplicationProxy.GetProxy(SPServiceContext ServiceContext) at
Microsoft.Office.Server.Search.WebControls.SearchCommon.GetSearchCenterUrl()
Correlation : 51c0ec9f-6402-400f-ed14-ee6800073b9c
Context : {}


Whether this error can be caused by factors other than associated with sharepoint?

office-sharepoint-server-administrationsharepoint-workflow
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

CaseyYangMSFT-4714 avatar image
0 Votes"
CaseyYangMSFT-4714 answered CaseyYangMSFT-4714 commented

Hi @splover,

Is there anything has been changed before the issue occurs?

You could use the following PowerShell commands to check if there are any timer jobs not running.

 $farm = Get-SPFarm
 $disabledTimers = $farm.TimerService.Instances | where {$_.Status -ne "Online"}

If an Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @CaseyYangMSFT-4714,

All of the timer jobs are running, your scripts showed nothing.
From the sharepoint side on server there was nothing changed before issues.

0 Votes 0 ·

Hi @splover,

Did you check the search service application? From the ULS log, this issue seems related to search service.

0 Votes 0 ·
sadomovalex avatar image
0 Votes"
sadomovalex answered

go to Central administration > Manage service applications and check whether Search service application is in Started state. Based on the error:

The search request was unable to connect to the Search Service

something may be wrong with search service app.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

splover avatar image
0 Votes"
splover answered CaseyYangMSFT-4714 commented

@sadomovalex, @CaseyYangMSFT-4714 thanks for respond.

Search service application is not present inside sharepoint central administration, but for searching is used external service - Solr. From Solr side everything is working fine - there is not any errors inside logs associated with sharepoint.
Additionally there is Sharepoint server search 15 in Windows services list, but it is disabled.

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @splover,

What error message did you get when opening library page?

0 Votes 0 ·
splover avatar image splover CaseyYangMSFT-4714 ·
0 Votes 0 ·
image.png (71.3 KiB)

Hi @splover,

As I could not reproduce the same issue, I suggest you open a ticket with Microsoft for furthur help.

0 Votes 0 ·
sadomovalex avatar image
0 Votes"
sadomovalex answered sadomovalex edited

Search service application is not present inside sharepoint central administration, but for searching is used external service - Solr. From Solr side everything is working fine - there is not any errors inside logs associated with sharepoint

this is fine that some external service is used for searching - no need to change that. Just some Sharepoint components may require standard Search service app to be provisioned. No need to create any content sources there - leave it empty (which means it won't perform search crawl) but try to create it so it will be listed in service applications list in Central administration:
131681-2021-09-13-17-37-35.png
And see will it help.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.