question

ShuxinYang-0870 avatar image
0 Votes"
ShuxinYang-0870 asked ShuxinYang-0870 commented

virtual machine remote connection issue

Hi
I just created a virtual machine in azure, I followed the steps on MSDN to install a desktop env on VM, everything works perfectly before I try to connect the VM with windows "remote desktop connection" (Windows 10), I can get into the login interface, after I input my username and password, it flashes back to my desktop's "remote desktop connection".
I've tried to restart the vm but it did not work, I've also tried different sessions in the login form, every session shows a error form in the remote window
Is anything I've missed? any kind of advice would be great, thank you!

azure-virtual-machinesremote-desktop-services
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

You will have to record a video to show what exactly happened. The words above are ambiguous and difficult to understand.

0 Votes 0 ·

@ShuxinYang-0870
Can you please share some screenshots to help us understand your issue better. Thanks.

0 Votes 0 ·
karishmatiwari-msft avatar image
1 Vote"
karishmatiwari-msft answered ShuxinYang-0870 commented

Customer posted the answer in the private comment. Sharing here for others to refer.

"The issue is regarding this link : https://docs.microsoft.com/en-us/azure/virtual-machines/linux/use-remote-desktop
The problem I got is every time I type in the username and password in the xrdp interface, the remote window closes.
I searched a lot and tried to repeat the steps, it turned out to be this command below probably got skipped.
echo xfce4-session >~/.xsession
Everything works perfectly after I run this command on my computer with powershell."

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thanks for sharing.

0 Votes 0 ·

Thanks, I was not that familiar with the process, thanks for helping

0 Votes 0 ·
Dev073 avatar image
0 Votes"
Dev073 answered

I would recommend to enable boot diagnostics and check the screenshot of the VM for further troubleshooting.

https://docs.microsoft.com/en-us/troubleshoot/azure/virtual-machines/boot-diagnostics

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.