question

SarthakKharia-6547 avatar image
0 Votes"
SarthakKharia-6547 asked SarthakKharia-6547 commented

Remote Desktop can't connect to the remote computer

As soon as I made some TCP setting changes on Azure VM,VM connection is stopped and I am not able to access the machine using RDP.

azure-virtual-machinesremote-desktop-services
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

liroyben avatar image
0 Votes"
liroyben answered SarthakKharia-6547 commented

Hello,

You must reset your network interface check this https://docs.microsoft.com/en-us/troubleshoot/azure/virtual-machines/reset-network-interface

Have a great day!

Please don't forget to Accept as answer and upvote :)

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Already tried that, as this link was shared in Microsoft's diagnosis of the problem

1 Vote 1 ·
liroyben avatar image liroyben SarthakKharia-6547 ·

Try to create a new network interface with a new ip and link to your VM

0 Votes 0 ·

I reset network interface by changing the private IP and deallocating the public IP, still no change

0 Votes 0 ·
SarthakKharia-6547 avatar image
0 Votes"
SarthakKharia-6547 answered SarthakKharia-6547 commented

Test connection using the Service: RDP And Protocol: TCP
is successful.

Network connectivity allowed. But still RDP is failing

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi, Have you tried resetting the RDP settings for Azure. ?

If you can't connect to a Windows virtual machine (VM), you can reset the Remote Desktop Services configuration (not supported on Windows domain controllers).
Steps here https://docs.microsoft.com/en-us/troubleshoot/azure/virtual-machines/reset-rdp

0 Votes 0 ·

reset the Remote Desktop Services configuration

Done this multiple times already, but no change

0 Votes 0 ·