question

AkilaIndusara-6442 avatar image
0 Votes"
AkilaIndusara-6442 asked karishmatiwari-msft edited

Mic get muted when i disconnected from RDP

I'm trying to see if I can use my music bots in an azure VM. when I connected to the VM using RDP and connect bots to the TeamSpeak server I want and play the music (using sinusbot) it works fine. but when I get disconnected from the VM, the bots get muted automatically. is there any reason for that?

azure-virtual-machinesremote-desktop-client
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ChristopherW-MSFT avatar image
0 Votes"
ChristopherW-MSFT answered AkilaIndusara-6442 commented

Hi @AkilaIndusara-6442 ,

It sounds like closing the RDP session is stopping the user session and it's pausing or ending the bot. You'll probably need to keep the session running after RDP disconnection for the bot to continue. You can keep a Remote Desktop Session open by enabling 'Configure keep-alive connection interval' in Remote Desktop Services.

This setting can be enabled under Windows Group Policy Editor.

 Start > Administrative Tools > Group Policy Management
 Local Computer Policy/Computer Configuration/Administrative Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Connections
 In Connections set 'Configure keep-alive connection interval' to Enabled > Set Keep Alive Interval (Minutes) > OK

If you login to a different Session/User, you should see that the first session is still active. You can change between these Sessions by closing Bastion and starting a new session, or by going to Task Manager > Users > Right Click User > 'Connect'


130319-image.png



image.png (237.9 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

i did it but still, the bots get muted. I appreciate you taking your time to answer this

0 Votes 0 ·
Dev073 avatar image
2 Votes"
Dev073 answered

its by behavior. there is no native way to suppress the auto mute.

However there are work around listed here. see if this helps for you.

https://forum.sinusbot.com/threads/disconnecting-rdp-bot-mutes-it-self.5521/

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.