question

Elia-1010 avatar image
1 Vote"
Elia-1010 asked ramr-msft edited

Cannot install azureml-sdk without dependency conflicts

I'm trying to install the latest azureml-sdk (1.34.0) inside a new conda env (with python 3.7) but the installation ends with the following error:

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
knack 0.7.2 requires argcomplete, which is not installed.
knack 0.7.2 requires colorama, which is not installed.
knack 0.7.2 requires pygments, which is not installed.
azure-functions-devops-build 0.0.22 requires jinja2, which is not installed.
azure-cli-core 2.10.0 requires argcomplete~=1.8, which is not installed.
azure-cli-core 2.10.0 requires colorama~=0.4.1, which is not installed.
azure-cli 2.10.0 requires azure-mgmt-keyvault~=2.2.0, but you have azure-mgmt-keyvault 9.1.0 which is incompatible.
azure-cli 2.10.0 requires cryptography<3.0.0,>=2.3.1, but you have cryptography 3.4.8 which is incompatible.
azure-cli-core 2.10.0 requires azure-mgmt-core==1.0.0, but you have azure-mgmt-core 1.3.0 which is incompatible.
azure-cli-core 2.10.0 requires msal~=1.0.0, but you have msal 1.14.0 which is incompatible.
azure-cli-core 2.10.0 requires msal-extensions~=0.1.3, but you have msal-extensions 0.2.2 which is incompatible.

How can I solve it?

130764-image.png


azure-machine-learning
image.png (109.5 KiB)
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@Elia-1010 Thanks for the question. Can you please add more details about the steps that you performed to install the latest azureml-sdk (1.34.0).
Troubleshooting document: https://docs.microsoft.com/en-us/python/api/overview/azure/ml/install?view=azure-ml-py#troubleshooting

0 Votes 0 ·
Elia-1010 avatar image
1 Vote"
Elia-1010 answered

@ramr-msft Thanks for your answer.
I've just run the following comands:

  1. conda create -n myenv python=3.7

  2. conda activate myenv

  3. pip install azureml-sdk --no-cache-dir

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

ramr-msft avatar image
0 Votes"
ramr-msft answered ramr-msft edited

@Elia-1010 Thanks for the details, We recommend that you always keep azureml-core updated to the latest version.

Upgrade a previous version:

 pip install --upgrade azureml-core

We are able to install the latest azureml-sdk (1.34.0) successfully without the above mentioned error in conda environment. Please find the below snapshot for the same.

130821-image.png



image.png (77.4 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@Elia-1010 Thanks, Please do consider clicking on "Accept Answer" and "Up-vote" on the post that helps you, as it can be beneficial to other community members. If you are interested in joining the VM program and help shape the future of Q&A: Here is how you can be part of Q&A Volunteer Moderators.

0 Votes 0 ·