question

JBINET-0964 avatar image
0 Votes"
JBINET-0964 asked joyceshen-MSFT commented

Exchange 2016 DatabaseAvailabilityGroup Extremely slow Powershell Answers

Version: Exchange 2016
Environment: 6 servers / DAG

Hi everyone, we are facing a strange thing related to Powershell and Exchange.

Everything works fine, except one point : Powershell commands seem hung, but finally respond after some minutes.

Example: Get-DatabaseAvailabilityGroup, Test-ReplicationHealth

Results are OK, the only problem is the time it takes to receive answers.

What could cause such strange behavior ?

Thanks in advance for your help !!!

office-exchange-server-administrationoffice-exchange-server-deploymentoffice-exchange-server-ha
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @JBINET-0964

What's your Exchange server 2016 CU version? When did this issue occur? Did you connect to the EMS directly or using remote powershell?

In addition, the Get-HealthReport and Get-ServerHealth cmdlets are used to learn about the health of the Exchange Server and understand if all the services are running as expected, or if there is an issue anywhere.

Please also check if there is any related logs recorded in the application log through event viewer. If no clues, we can try to set the event log level to high and check again.

 Set-EventLogLevel -Identity "Exchange01\msexchangeIS\high availability" -Level High

Don't forget to turn the level back to the previous status after you record the log.


If an Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


0 Votes 0 ·

Hi @JBINET-0964

Is there any update about your issue? Could you please check the event log to get more information?

0 Votes 0 ·
AndyDavid avatar image
0 Votes"
AndyDavid answered

Do you have multiple sites?
What does Task Manager show on the servers? Is IIS using alot of CPU or RAM? Are the servers sized correctly?

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JBINET-0964 avatar image
0 Votes"
JBINET-0964 answered JBINET-0964 commented

Hi and thank you for your answer !

Yes, they are on 2 different sites, but we don't have any issue between them.

All servers are currently very under-used ( 10% CPU / 30% RAM/ 10% DISK).

Is there any way to debug/log commands or find a way to identify what causes the delays ?

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

What commands are affected? All of them ? Some?

0 Votes 0 ·

Get-DatabaseAvailabilityGroupNetwork => wait 30 minutes and you get a result
Get-DatabaseAvailabilityGroup -status => slow with "status" option, fast without it
Test-ReplicationHealth => very slow, but only succes results after 30 minutes

0 Votes 0 ·