question

TimSchonborn-3020 avatar image
0 Votes"
TimSchonborn-3020 asked TimSchonborn-3020 commented

React deployment keeps failing with ESOCKETTIMEDOUT

I'm trying to deploy my react app using the vscode extension. However, since a few days I get an error and I don't understand where it's coming from. I would appreciate any help/advice!

 1:12:52 PM web-app: Starting deployment...
 1:12:54 PM web-app: Creating zip package...
 1:12:54 PM web-app: Ignoring files from "appService.zipIgnorePattern"
 "node_modules{,/**}"
 ".vscode{,/**}"
 1:13:07 PM web-app: Zip package size: 3.12 MB
 1:13:08 PM web-app: Fetching changes.
 1:13:09 PM web-app: Cleaning up temp folders from previous zip deployments and extracting pushed zip file /tmp/zipdeploy/c67b0dc7-bbf5-4bd7-a194-bc71e0635617.zip (2.99 MB) to /tmp/zipdeploy/extracted
 1:13:12 PM web-app: Updating submodules.
 1:13:13 PM web-app: Preparing deployment for commit id 'bb15425480'.
 1:13:14 PM web-app: Repository path is /tmp/zipdeploy/extracted
 1:13:14 PM web-app: Running oryx build...
 1:13:14 PM web-app: Command: oryx build /tmp/zipdeploy/extracted -o /home/site/wwwroot --platform nodejs --platform-version 14 -i /tmp/8d97770a52fffdd -p compress_node_modules=tar-gz --log-file /tmp/build-debug.log 
 1:13:17 PM web-app: Operation performed by Microsoft Oryx, https://github.com/Microsoft/Oryx
 1:13:17 PM web-app: You can report issues at https://github.com/Microsoft/Oryx/issues
 1:13:17 PM web-app: Oryx Version: 0.2.20210605.4, Commit: d2189daf082e06fece90175ba65603f21421cc64, ReleaseTagName: 20210605.4
 1:13:17 PM web-app: Build Operation ID: |OLmCAM+Q8Vg=.7cbd4fb7_
 1:13:17 PM web-app: Repository Commit : bb1542548077428caf0c850f5404031d
 1:13:17 PM web-app: Detecting platforms...
 1:13:19 PM web-app: Detected following platforms:
 1:13:19 PM web-app:   nodejs: 14.17.6
 1:13:20 PM web-app: Using intermediate directory '/tmp/8d97770a52fffdd'.
 1:13:20 PM web-app: Copying files to the intermediate directory...
 1:13:20 PM web-app: Done in 0 sec(s).
 1:13:20 PM web-app: Source directory     : /tmp/8d97770a52fffdd
 1:13:20 PM web-app: Destination directory: /home/site/wwwroot
 1:13:21 PM web-app: Using Node version:
 1:13:21 PM web-app: v14.17.6
 1:13:21 PM web-app: Using Yarn version:
 1:13:21 PM web-app: 1.22.10
 1:13:22 PM web-app: Running 'yarn install --prefer-offline'...
 1:13:22 PM web-app: yarn install v1.22.10
 1:13:23 PM web-app: [1/4] Resolving packages...
 1:13:27 PM web-app: [2/4] Fetching packages...
 1:14:06 PM web-app: info There appears to be trouble with your network connection. Retrying...
 1:14:46 PM web-app: info There appears to be trouble with your network connection. Retrying...
 1:15:25 PM web-app: info There appears to be trouble with your network connection. Retrying...
 1:16:05 PM web-app: info There appears to be trouble with your network connection. Retrying...
 1:17:00 PM web-app: error An unexpected error occurred: "https://registry.yarnpkg.com/@material-ui/icons/-/icons-4.11.2.tgz: ESOCKETTIMEDOUT".
 1:17:00 PM web-app: info If you think this is a bug, please open a bug report with the information provided in "/tmp/8d97770a52fffdd/yarn-error.log".
 1:17:00 PM web-app: info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

package.json:

 package.json:
    
     {
       "name": "web-app",
       "version": "0.1.0",
       "private": true,
       "dependencies": {
         "@azure/msal-browser": "^2.16.1",
         "@azure/msal-react": "^1.0.1",
         "@material-ui/core": "^4.12.0",
         "@material-ui/icons": "^4.11.2",
         "@testing-library/jest-dom": "^5.11.4",
         "@testing-library/react": "^11.1.0",
         "@testing-library/user-event": "^12.1.10",
         "@types/jest": "^26.0.15",
         "@types/node": "^12.0.0",
         "@types/react": "^17.0.0",
         "@types/react-dom": "^17.0.0",
         "clsx": "^1.1.1",
         "history": "^5.0.0",
         "react": "^17.0.2",
         "react-dom": "^17.0.2",
         "react-router": "^5.2.0",
         "react-router-dom": "^5.2.0",
         "react-scripts": "4.0.3",
         "recharts": "^2.1.2",
         "typescript": "^4.1.2",
         "web-vitals": "^1.0.1"
       },
       "scripts": {
         "start": "react-scripts start",
         "build": "react-scripts build",
         "test": "react-scripts test",
         "eject": "react-scripts eject"
       },
       "eslintConfig": {
         "extends": [
           "react-app",
           "react-app/jest"
         ]
       },
       "browserslist": {
         "production": [
           ">0.2%",
           "not dead",
           "not op_mini all"
         ],
         "development": [
           "last 1 chrome version",
           "last 1 firefox version",
           "last 1 safari version"
         ]
       },
       "devDependencies": {
         "@types/react-router-dom": "^5.1.7"
       }
     }


azure-webapps
· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I cant figure out how to edit the question, but I'd like to add that my network connection doesn't seem to be the issue, it works fine and I tried it on multiple networks. Furthermore, the material-icons link provided in the error message works fine if I try to access it..

0 Votes 0 ·
ryanchill avatar image ryanchill TimSchonborn-3020 ·

Can you elaborate on multiple networks @TimSchonborn-3020? Also, can you provide your package.json, I'd like to see if I can repro the issue on my end.

0 Votes 0 ·

Hey Ryan,

multiple networks as in tried it at my place (wifi+ethernet), my gf's (wifi), office (wifi). I'm still stuck and can't figure out why this isn't working. I've added package.json to the question.

0 Votes 0 ·
Show more comments

@ryanchill just tagging you to see if there's any update? Still couldn't get vscode to deploy the application. I don't think it's related to my network connection at all.

0 Votes 0 ·

0 Answers