question

ShantimohanElchuri-8757 avatar image
0 Votes"
ShantimohanElchuri-8757 asked KyleWang-MSFT answered

Unable to debug Xamarin.Forms iOS project after publishing app to AppStore

I have recently published a new version of an app to both Play Store and App Store. Now I changed to "Debug" and try to debug. In Android the control breaks at a break-point but in iOS the execution is not stopping at any break-point.

I did change the setting that I modified to publish in Release mode. So what am I missing. This is happening only in iOS.

I am using VS 2019 Community Edition Version 16.11.2.

dotnet-xamarinformsdotnet-ios
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

KyleWang-MSFT avatar image
0 Votes"
KyleWang-MSFT answered

@ShantimohanElchuri-8757 Open the project property window and go to "iOS Build" and set Linker Behavior to "Don't Link". And click "Build->Advanced" to check if "Debugging inforamtion" is "Portable". Delete bin and obj folder under the project path, clean the project and rebuild it. If all of these not work, please report a problem on Developer Community.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

That worked. I changed Debug Information setting from Full to Portable and now it is stopping at break points. But can you explain the following:

  1. In another project it was stopping at break points even with this setting to Full.

  2. Before I reported here that it misbehaved, it worked at least once.

PS: It stopped responding to break points again. Even deleting bin and obj folders and rebuilding didn't help.



0 Votes 0 ·
KyleWang-MSFT avatar image KyleWang-MSFT ShantimohanElchuri-8757 ·

@ShantimohanElchuri-8757 Since this issue is hard to reproduce, please report it as a problem on Developer Community.

0 Votes 0 ·