question

RickDanforth-3099 avatar image
0 Votes"
RickDanforth-3099 asked KyleXu-MSFT commented

Unable to set Exchange Hybrid Server send-connector certificate

I have created a new externally signed certificate for our Hybrid Exchange server. It has been enabled for both IIS and SMTP, and we have restarted the server twice. The new certificate shows up as being enabled for SMTP.

However, when we are trying to run the commands to replace the send-connector certificate, as seen131909-exc-cert2.png in image, we get the error:



The given certificate is not enabled for SMTP protocol. Only certificates enabled for SMTP protocol can be set on Send
Connectors. To enable a certificate for SMTP, please use 'Enable-ExchangeCertificate' cmdlet.

The certificate definitely appears to be enabled for SMTP, and we have restarted the server twice since this. Could anyone please suggest to me why this error would still appear?

For added context, this is the only Exchange Hybrid server in our environment. And all commands are being run from it.


office-exchange-server-administrationoffice-exchange-server-mailflowoffice-exchange-server-connectivityoffice-exchange-hybrid-itprooffice-exchange-server-itpro
exc-cert2.png (68.8 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@RickDanforth-3099

Any update about this thread now? Did you replace this certificate successfully?

0 Votes 0 ·

1 Answer

AndyDavid avatar image
0 Votes"
AndyDavid answered AndyDavid commented

Any help from:
https://docs.microsoft.com/en-us/answers/questions/58292/hybrid-configuration-wizard-says-certificate-has-n.html

Came across this issue in our environment trying to add new servers to an existing send connector - the cmdlet I was using was Set-Sendconnector -SourceTransportServers @{add='SERVERNAME'} which is in effect re-adding all existing servers and the new server to the connector. I found that the error was not related to the new server but somehow one of the existing servers did not have the SMTP service assigned to the cert used by the send connector. Running Enable-ExchangeCertificate on the existing server and then re-running the additions to the send connector resolved the issue.

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello Thank you for your comment. I will try this tomorrow!

Do you think this will be influenced by the fact there is only one Exchange server in our environment?

0 Votes 0 ·
AndyDavid avatar image AndyDavid RickDanforth-3099 ·

Well, shouldnt haha. But wouldnt hurt to try .

0 Votes 0 ·