question

BoopathiSubramaniam-6294 avatar image
0 Votes"
BoopathiSubramaniam-6294 asked BoopathiSubramaniam-6294 commented

CI and Baseline isn't work

Hello,

I have created the Configuration Item and Baseline as per the attached xml file. Deployed it to a collection.

132087-dc0c1314-910e-4769-8ecc-e76e96978993.xml132088-c26079d0-c81e-4f31-9ce2-31334125739d.xml


Present Registry settings
131930-reg.jpg



I am using Windows 10. But I do not find below registry keys created.

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0]
"1001"=dword:00000003
"1004"=dword:00000003

Please help me if I'm doing something incorrectly

mem-cm-general
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

RahulJindal-2267 avatar image
0 Votes"
RahulJindal-2267 answered BoopathiSubramaniam-6294 commented

Have you enabled remediation in your CI and deployment?

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello Rahul,

Yes. I have enabled it.

0 Votes 0 ·
AllenLiu-MSFT avatar image
0 Votes"
AllenLiu-MSFT answered BoopathiSubramaniam-6294 commented

Hi, @BoopathiSubramaniam-6294
Thank you for posting in Microsoft Q&A forum.

We may check the Compliance Rules of the Settings of the CI, have we checked the "Remediate noncompliant rules when supported"?
132184-1.jpg


Also check the "Remediate noncompliant rules when supported" in the deployment of the CB.

132185-2.jpg

Then we can check the CI results on client after deployment, we can manually "Evaluate" it and click "View Report" to check the results.
132186-3.jpg


If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



1.jpg (65.9 KiB)
2.jpg (45.9 KiB)
3.jpg (57.4 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello AllenLiu,
Thanks for your detailed step132369-1.jpg.


132370-2.jpg



Above are the CI and Baseline configurations.
I do not find below registry keys created.

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0]
"1001"=dword:00000003
"1004"=dword:00000003
Not sure where is the mistake.
Please help me if I'm doing something incorrectly

0 Votes 0 ·
1.jpg (124.7 KiB)
2.jpg (161.1 KiB)
RahulJindal-2267 avatar image
0 Votes"
RahulJindal-2267 answered

Can you share the screenshot of your baseline deployment?

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

AllenLiu-MSFT avatar image
0 Votes"
AllenLiu-MSFT answered BoopathiSubramaniam-6294 commented

Hi, @BoopathiSubramaniam-6294
Thank you for the feedback.

I test in my lab with the same configuration like yours and get the key created correctly.
132657-1.jpg


So, I will double confirm with you, have you also check the "Remediate noncompliant rules when supported" in the deployment of CB?
And manually evaluate it in configuration manager properties? What's the compliance state of your CB?
132648-2.jpg



1.jpg (54.3 KiB)
2.jpg (38.9 KiB)
· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hello AllenLiu,

Thanks.
Refer the below screenshot.
132815-13.jpg132822-12.jpg



I do not see the CI in Configuration Manager -> Configurations

0 Votes 0 ·
13.jpg (41.7 KiB)
12.jpg (71.3 KiB)
AllenLiu-MSFT avatar image AllenLiu-MSFT BoopathiSubramaniam-6294 ·

It seems there is no issue of your configuration, but you do not see the CI in Configuration Manager\Configurations, you may need to check whether the deployment has deployed to the clients successfully. Are you sure you have deployed Configuration Baseline to the clients?

0 Votes 0 ·
AllenLiu-MSFT avatar image AllenLiu-MSFT AllenLiu-MSFT ·

It seems there is no update for a couple of days. May we know the current status of the problem? Is there any other assistance we can provide?

0 Votes 0 ·
AllenLiu-MSFT avatar image AllenLiu-MSFT BoopathiSubramaniam-6294 ·

Is there any update?

0 Votes 0 ·

Hello AllenLiu,

I did not test in another device. We can close this thread.

0 Votes 0 ·