question

IanMarsden-1078 avatar image
0 Votes"
IanMarsden-1078 asked EchoDu-MSFT commented

User Profile Service Application - Clicking Manage throws exception.

We are currently in the progress of migrating our SharePoint 2016 on-premise site to 365 and everything has been working fine, nothing has been touch by any administrators. However, out of the blue yesterday morning at 6:10am the User Profile Server started erroring.

A summary of the errors it is throwing are:



The Execute method of job definition Microsoft.Office.Server.UserProfiles.LMTRepopulationJob (ID 9fd04747-aa54-4616-9946-bd6f352a8095) threw an exception. More information is included below.

Access is denied.. (Correlation=e6b0ef9f-f052-500e-6758-022d1aa4e7c1)



The Execute method of job definition Microsoft.Office.Server.UserProfiles.FeedCacheRepopulationJob (ID f99c8464-363f-483f-b238-c7038616c620) threw an exception. More information is included below.

Access is denied.. (Correlation=efb0ef9f-10e9-500e-6758-0d73f71237f8)



The Execute method of job definition Microsoft.Office.Server.ActivityFeed.ActivityFeedUPAJob (ID ec9a7806-f483-4091-ac56-1f8c6e11944a) threw an exception. More information is included below.

The trust relationship between the primary domain and the trusted domain failed.
. (Correlation=2fb1ef9f-b087-500e-6758-0a262e71128a)



A failure was reported when trying to invoke a service application: EndpointFailure
Process Name: OWSTIMER
Process ID: 8528
AppDomain Name: DefaultDomain
AppDomain ID: 1
Service Application Uri: urn:schemas-microsoft-com:sharepoint:service:d9c6f65ff2184a85ba31abc24ef3dad6#authority=urn:uuid:f5195237866d468498fa1c2a0ef3b64e&authority=https://<appserver>:32844/Topology/topology.svc
Active Endpoints: 1
Failed Endpoints:1
Affected Endpoint: http://<appserver>:32843/d9c6f65ff2184a85ba31abc24ef3dad6/ProfileService.svc



Failure trying to synch web application 317629d1-6202-4268-b669-eacf6f38861f, ContentDB 8ab206bd-ebb8-4f96-9ebf-4b147cc7a4e9 Exception message was Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.ApplicationProperties ProfilePropertyCache does not have 74b5460c-e894-4537-acc3-2b7ebc36efe1
at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.GetApplicationPropertiesFromCache()
at Microsoft.Office.Server.UserProfiles.UserProfileGlobal.GetDataUsingCurrentHttpContextAsCache[T](SPIisWebServiceApplicationProxy webServiceProxy, Func`1 dataGetter, String cacheKey)
at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_ApplicationProperties()
at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_PerfmonInstanceHandle()
at Microsoft.Office.Server.UserProfiles.ContentDBSynchronizer..ctor(ELogType logType, SPContentDatabase cdb, SPJobState jobState, SyncType syncType, WSSSyncUsageEntry usage, String[] excludedAccountsRegexStrings)
at Microsoft.Office.Server.UserProfiles.WSSProfileSyncJob.Execute()



Failure during sweep synch of content database WSS_Content. Exception was UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.ApplicationProperties ProfilePropertyCache does not have 74b5460c-e894-4537-acc3-2b7ebc36efe1.



Central Admin and system pages on sites are still loading and some non-custom forms are still working but most pages are displaying the error:

Sorry, something went wrong
An unexpected error has occurred.
TECHNICAL DETAILS
GO BACK TO SITE

Also, when go onto the User Profile Service Application and click Manage a Correlation ID error is given.

I have been trying to make some lighter changes to the site as I am reluctant to follow many posts on the web to resolve the issue as they mention previous upgrades or work that has been going on within the system before these problems occurred, but we have touched anything for a while.

In the logs, the correlation id seems to point towards the same issues such as:

  • Exception thrown while adding control 'ASP.SocialDataUserControl': System.NullReferenceException: Object reference not set to an instance of an object.

  • Exception thrown while adding control 'Microsoft.SharePoint.Portal.WebControls.SocialNotificationControl'

  • ProfilePropertyCache could not be refreshed for UPA Proxy


    [1]: /answers/storage/attachments/132414-output.txt


For the trust issues we have disconnected both APP and WFE server from the domain and readded but this did not change anything.

office-sharepoint-server-administration
output.txt (24.2 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I have deleted and readded the Proxy which now means that I can see the SharePoint Pages etc but still cant Manage the User Profile Service Application

I deleted the User Profile Application Proxy and readded it ....

$proxyName = "User Profile Service Application Proxy" # This is whatever you want to call the proxy
Add-PSSnapin sharepoint
$upa = Get-SPServiceApplication | ? {$_.typename -eq "User Profile Service Application"}
New-SPProfileServiceApplicationProxy -Name $proxyName -Uri $upa.uri.absoluteURI

Followed in this guide: https://joshroark.com/sharepoint-a-troubleshooting-guide-for-userprofileapplicationnotavailableexception/

132398-output.txt



0 Votes 0 ·
output.txt (24.2 KiB)
EchoDu-MSFT avatar image
0 Votes"
EchoDu-MSFT answered EchoDu-MSFT edited

Hello @IanMarsden-1078 ,

Welcome to Q&A Forum!

Please following steps:

1.You are using the Farm Account

2.The Farm account is added to local administrator group during starting UPS service.

3.Make sure your user is the part of local system administrator group

4.Go to Central Administration >> Application Management >> Manage services on server >> Check if there is Distributed Cache Service, if so, stop it.

5.Try to increase the timeout for the LMTCache and DistributedActivityFeedCache using PowerShell command below:

 $lmtcache = Get-SPDistributedCacheClientSetting -containertype DistributedActivityFeedLMTCache
 $lmtcache.RequestTimeout="10000"
 Set-SPDistributedCacheClientSetting -ContainerType DistributedActivityFeedLMTCache $lmtcache 
    
 $feedcache = get-SPDistributedCacheClientSetting -containertype DistributedActivityFeedCache
 $feedcache.RequestTimeout="10000"
 Set-SPDistributedCacheClientSetting -ContainerType DistributedActivityFeedCache $feedcache

6.Then use the following command to populate the cache quickly:

 Update-SPRepopulateMicroblogLMTCache -ProfileServiceApplicationProxy <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] 
    
 Update-SPRepopulateMicroblogFeedCache -[AccountName <AccountName>] -ProfileServiceApplicationProxy <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-SiteSubscription <SPSiteSubscriptionPipeBind>]-[SiteUrl <SiteURL>]

Reference:

Thanks,
Echo Du
=================================
If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

IanMarsden-1078 avatar image
0 Votes"
IanMarsden-1078 answered EchoDu-MSFT commented

This didnt work so I took some other advice from the Reference link you posted which suggested to delete recreate the User Profile Application, as I see that recreating the User Profile Application Proxy has resolved some issues.

This worked and its now all good. Thanks for your assistance.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @IanMarsden-1078 ,

I'm glad to hear that your problem has been solved.

If the answer is helpful to you, you can accept it as answer. The behavior will help others who meet the similar issue in the future quickly find the correct answer.

Thanks,
Echo Du

0 Votes 0 ·