question

Lavan96-1266 avatar image
0 Votes"
Lavan96-1266 asked DSPatrick commented

My server is not booting with 2 network card

Hi,
Some server exerts can you please help.
I have set up a standalone server with AD, DNS, DHCP and WDS.
I have 2 network cards on the server I set up.
I have all the time used local network without internet acess on the main card.
The other network card I connect the 4G router directly.
Once I have done this, I am unable to boot the PCs through WDS. It appears that the server does not assign any IP addresses to the clients. When I unplug the network cable I have, I have to boot it again.
I need our internet on the server to update it anytime.
Anyone know what the cause may be? possibly if you have any articles or youtube video that can help me?

windows-serverwindows-active-directorywindows-dhcp-dns
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

DSPatrick avatar image
1 Vote"
DSPatrick answered DSPatrick commented

Multi-homing a domain controller will always cause no end to grief for active directory DNS. You'll need to disable one of the adapters.

--please don't forget to upvote and Accept as answer if the reply is helpful--



· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Just checking if there's any progress or updates?

--please don't forget to upvote and Accept as answer if the reply is helpful--



0 Votes 0 ·
LimitlessTechnology-2700 avatar image
0 Votes"
LimitlessTechnology-2700 answered

Hello @Lavan96-1266

Yes, this is a frequent issue. I would recommend 3 ways:

  • add the loopback adress as Host in the HOSTS file of the WDS server:
    \Windows\System32\drivers\etc\ to include "127.0.0.1 yourhostnamehere".

  • Change the binding of the services to the correct NIC:
    find the BindPolicy & BindInterfaces registry (HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WDSServer\Providers\WDSPXE)
    And set 0 for Excluding the NIC, 1 for Including

  • Enable just the need protocols on the 4G Interface Adapter:
    From the Properties of the adapter, disable one by one the protocols and services enabled. I would start for the one "Client for Microsoft Networks", then try.
    The main one to leave enabled is the TCP/IP v4, of course)

Hope this helps in your case,
Best regards,

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.